ZSceneManager plugin - (SubTools folders)

ahtiandr: can you contact me (http://exoside.com/company/contact/) and tell me how to reproduce the Imbed value issue (I failed to reproduce it with DemoSoldier on my computer…).
I plan to release 1.3 soon, and would like to fix this issue ASAP.

Aymeric, ][-][4Z4R][)), Maudeeb, Monkyfutz and Wyatt: Thanks a lot for the kind words!

Hi, i was trying out the free version and followed the instruction of loading a tool and then start the scene manager plugin, it will start up but my zbrush will prompt an “abnormal termination : recovered files stored in the recovered files’ directory and will …” and will just crash. interestingly i can still play around with the scene manager though but the zbrush has crashed.

did i do anything wrong? thanks

Hi zenarc,
Can you send me more information by email : http://exoside.com/company/contact/

  • your OS
  • ZBrush version
  • Does it happens with every Tool?

This looks great and I plan on downloading it tonight. This is the first day that I’ve seen anything about this plugin and I just wonder if, before I render using Keyshot I need to do anything to the file–or can I keep layers in assigned groups?
If you have anything specific about rendering in Keyshot while using ZSceneManager, I would like to know.

Thank you.

Hi ArtBot,

I have not tested it with KeyShot, but ZSceneManager should be compatible with KeyShot. You don’t have to do anything special.

It seems that it lost UV-s after altering with merge for sculpt? This is common or is just on my comp?
This little thing is a major problem for me.

It seems to be the case in my tests. You could recover it with copy paste UVs from backups, but it is extra work.

Hi all,
*** ZSceneManager 1.3 is released !!! ***

You can download it here: Download ZSceneManager 1.3

Even if there is no new big feature (as Merge for Sculpt in 1.2), 1.3 adds important things, few new features and polish or fix other things. So, it’s highly recommended to update to 1.3!

What’s new :

  • “Merge for Sculpt” maintains UVs, polygroups, masking and EdgeCreasing back and forth (in ‘Merge for Sculpt’ and ‘Transfer to SubTools’ actions)
  • New columns: ‘Point Count’ and ‘Has Layer’
  • fix “Brush Imbed at -70” and few other bugs (ZSphere…)
    -… more information in this document
    Thanks everybody for your comments and request. It allows me to improve ZSceneManager!

Happy ZBrushing!

Thanks a lot. Merge for sculpt is now more flexible than transpose master by far. This plugin is really worth to buy.

For sculpt to merge
Something that I would suggest is to add automatically a layer if the subtool has layers and none is in recording mode. Probably the best rule is to add a layer always, specially if the model has layers already.
The reason is that if the subtool has layers and not in recording mode any mesh modification will be lost as soon we manage the layers. It is like this new info is floating in nowhere. Any change wont be permanent (unless we collapse the layers before to touch them). This error is likely to confuse people as they will see they can not keep the changes done and the layers.

This is not specific of Zscenemanager, as would happen also in transpose master (but transpose master has layer option). Zbrush normally tell us that we can not modify the mesh with layers without a layer in recording mode and stops us doing that. This message appears often, but your plugin override this error message making the user no aware of the problem.

Obviously there is the workaround of checking all layers has recording layers or no layers, but it can be a lot of work if we have lots of subtools.

Hey Altea,
Thanks. Good point!
For sure I need to do it in future versions.
Right now (with 1.3), you can at least very easily watch the new ‘Layer’ column in ZSceneManager to check if you have layers or not.

Currently your plugin is the only way in Zbrush to scale several subtools with subdivisions without losing the detail.

Transpose master will go to the lower subdivision and scale the meshes. But the subdivisions won’t scale (a problem of Zbrush), becoming blurred if scaled up or messy if scaled down when subdivisions are recovered.

Because your plugin and merge for sculpt can do it in high subdivision doesn’t have this problem.

Another thing. I have noticed that it crashes Zbrush when topology is modified in merge to sculpt. It is not a big deal it can not do that, as transpose master cant either, but perhaps it should have some kind of warning.

Yes. It should absolutly not make ZBrush crash! I will fix it as soon as I get a little bit of time for this…

Hello I wonder if this is a bug, but I am unable to use “Merge Subtools” with multiple subtools.

Anyway great plugin I’m glad I bought it xD!!

Ignition, it works here with the last version, with and without layers or subdivisions. Have you tried with the star included in Zbrush, and if it works, the models that don’t work have something special?

Is possible to add a shortcut to the update tree button? Or to any of the other menu of the plugin.

That’s weird it works or kind of works.
I have 3 subtools name


These 3 subtools were made with the “Insert Sphere” brush then I Group Split.
Here is a video: https://youtu.be/qTlec3Xiddk

I tried merging them and told me to update my tree, and after I did that they were still unable to merge.

Then I tried(accidentally) naming the 3 subtools


And it worked, in 1.2 I was still able to merge the 3 subtools on the very top, is this suppose to happen?

There was also a potential bug with the Polypaint/Texture, I was struggling trying to make my sculpt into a silhoutte by using the “V” key, I didn’t apply any paint or materials and some of the subtools wouldn’t change to black and I tried searching through color,layers, and other ways to fix it. Then I was left with zSceneManager and notice Polypaint/Texture, and disable the Polypaint and it worked. Does zSceneManager automatically applies polypaint?

And sorry for asking too much questions ^^;;

But, how do I disable the creation of “-Dummy-<dummy>PMD_…etc”?, every time I launch ZScenemanager it makes one and I have to go into Subtools to delete it.
or everytime I update Full Tree, it makes a subtool on the very top.</dummy>

The hotkey for “UpdateFullTree” is Alt-U.
You can define your own hotkeys in Zplugin > ZScene Manager > hotkeys sub palette. Just use the standard CTRL-ALT-click on the buttons to redefine the hotkey.


  • Based on your description of the “Merge SubTools” issue, I changed my code. The issue should be fixed now. I will release a 1.31 ASAP.
  • About “polypaint” button automatically applied: It should not happen. If it happens it’s a bug but it depends on what you have done before “polypaint” has been enabled. Can you tell me how I can reproduce this (in a private message, with a ZTL is needed).
    NB: if you click on the icon in ‘PP’ column of ZSceneManager, it activates/deactivates the polypainting.
  • About the Dummy SubTool : you can disable the option “Auto Add Dummy SubTool” in “Options…” sub-menu.
    But it’s highly recommended to let it enabled (see http://www.exoside.com/zscenemgrdata/ZSceneMgrUserDocumentation.pdf in page 8-9).


For the polypaint, I’m not sure what I did and I am unable to reproduce it.
I’m sorry ^^;;

and thank you for the help!!

Hi there,
I finally purchased the pro version - really that thing is a life safer.
One question though, not a biggy but whenver I close Zbrush without closing SceneManager first I get an error screen saying it has crashed. I assume it’s because it is standalone and loosing connection but I haven’t seen it mentioned before.

Anyway, it’s a purchase I won’t regret ever !