Tutorial: ZBrush normal maps and 3dsmax v8

Video tutorial: ZBrushElephant.wmv (3.075 KB)

Hear are some guidlines for using ZBrush normal maps is 3dsmax. Generate you normals maps with the ZMapper tool, remember to use the right configuration file. Download it here: 3dsmax8modifiedE.zmp. The default 3DS Max7_TangentSpace_BestQuality.zmp file causes artifacts at the seams. Export the normal map to a file, use the *.bmp file format if you want to use the realtime preview in the 3dsmax viewport.
Import the mesh into 3dsmax and assign a material. Assign a Normal Bump to the bump map slot.

For a realtime preview in the viewport you use the DirectX 9 Shader material. (You must have DirectX 9 enabled). Use the RTTNormalMap.fx DirectX 9 Shader. Comment: mental ray doesn’t support DirectX 9 Shaders but for the scanline renderer you can use a standard material. If you don’t have a diffuse map (yet) you can assign a single color bitmap.

This is a screendump of the Troll with the DirectX 9 realtime shader.

This is a screendump of the Elephant with the DirectX 9 realtime shader. The Elephant uses AUV mapping.

Thanks again CvH! This is good info!
Just to let you know that Eblondin over at CGTalk has a Max 8 ZMapper ZMP preset. …found here… that you might be interested in. I havent tried it myself yet.
Appreciate your tutorial!
Upham :slight_smile:

Thanks this is exactly what caused the seams in 3dsmax. I have tried it in 3dsmax and it works. :smiley: :wink: This is realy great. I will edit the above post and remove the part with the seam problems.

Hey guys, be sure to check out this HSLS shader made by Ben Cloward ,instead that the one which comes with max.


Despite sometimes it crashes (be sure to save or hold your scene before loading into the material editor), most of the times works very good. The support for specular channel and three lights makes it really good for previewing normal maps.


hey Cvh, it doesn’t seem to work for me on my 3ds max 8 with sp1,am i requiered to meshsmooth or torbosmooth my model like with displacement mapping?! is there any mapping procedure needed in zbrush or in 3ds max prior to import/export? is there any importance to bump numeric value in 3ds max ?!

hope for your help, and thanks for all taking the time to write down this tutorial and supporting this awesome community, i can’t wait for you’r next post :smiley:

and like all i’m still waiting for the zbrush to 3ds max pipeline…


No MeshSmooth or TurboSmooth is needed for normal maps (as long as the normal map is computed with the right algorithm). You probably forgot to enable the DirectX 9 driver. Of course you must have DirectX 9 installed before you can enable it. DirectX 9 is on the 3dsmax installations disks. Check your settings in the Customize/Preferences… menu from 3dsmax.

Just to let you know that Eblondin over at CGTalk has a Max 8 ZMapper ZMP preset. …found here… that you might be interested in. I havent tried it myself yet.

Heh. Thanks for giving me credit man :cool:

I posted those presets here on zbrush central as well.

Rock on guys. good tut CvH

thanks CvH for the quick reply. i did set my display to directx that part is fine, i can also see the normal compute correctly as i move over it with a light source’ i can see the shadows act like they sould, base on the added information taken from zbrush, my problem is that unless i apply mesh smooth to it or turbosmooth it keep resulting in the same low res mesh that i import from zbrush prior to the normal map,it seems to lay the normal map information correctly but it seems more like standard bump map it doesn’t seem to deform my geometry…:confused: i do all the settings as illustrated, when using directx i dont see the proper high res mesh in the viewport,all i see is my low res mesh colored in blue :roll_eyes:

i’m sure that there is something very basic that i’m missing,but i have no idea what it is…did any one encounter any such problems with 3ds max 8 sp1?! maybe if i was to remove it it would work?!..i heven’t had the opputinty to test normal mapping before…i’m new to normal mapping…

thanks for your time CvH, and any one else who is willing to help:+1:

sorry for my english


Now I know what you mean. When you import the mesh you get a mesh with facets. The normals at the vertices are wrong. To solve this without increating the number of polygons I converted the mesh to an EditablePoly enabled the NURMS subdivision and set the number of iterations to 0. The elephant on the front is probably what you get. Normal mapping in 3dsmax does’t deform the geometry.

hey CvH, yes that is exactly what i’m getting !!! …i tried your suggestion and it got me even more frustrated:cry: your mesh seems so smooth in the viewport with iterations set to 0 :confused: at my viewport with iteration set to 0 it looks crappy…the only thing is to set render iterations to 2 ,which pretty much does exactly the same thing as meshsmooth…so i don’t know. i hoped that it wasn’t just my problem and that maybe other users will say they face the same issues,any way it’s remain a mystery to me…

i can think of one way that might help to signal out if the problem is with me specific,and that is if you’ll wouldn’t mind sending your 3ds max file,and then to see if i get the same results as you in viewport/render.

i do apologize for bugging you like this,it’s just that this is a real pain in my :eek:

anyway thanks for your time, i won’t bother you again(alreay hijacked your beautifu tutorial thread).

Maybe this will help. Remember to do something back for the communitie. http://www.microcan.nl/ZBrushTutorial/Elephant.zip

Thanks again for your contribution…
im confuse with the second step related to DirectX9 shader, how i can load from the fx file?

To answer you question I made this little video tutorial.

Video tutorial: ZBrushElephant.wmv (3.075 KB)

that was awesome!!! thanks allot for the video:)

now all we need is the video for inside zbrush export/import procedure and we are all set :wink:

it seem that we will not need the official 3ds max to zbrush pipeline after all:sunglasses:

exellent :+1: :+1: :+1:

Thanks a lot CvH

I asumed al you guys already watched this video tutorial, it gives you al you need at the ZBrush side:

Each time i try to load the DirectX Shader 3DMax crash!
Is there an explanation for this and how to resolve it?
Thanks in advance

Be sure to have the latests drivers for your graphic card installed. Also, the latest directx is a must (Directx 9.0c).
Which shader are you trying to load? have you tried the one from Ben Cloward? (http://www.monitorstudios.com/bcloward/shaders_NormalMapSpecular3lights.html)

Good luck

Yes Jothun i have the 9.0C version installed.
Thanks anyway

ps: directx 9 shader


A crash with 3dsmax can have many causes, do you have DirectX 9c and the latest drivers for you graphics card installed? Does you graphics card support DirectX 9c and did you enable it. As you can see in the video tutorial it works at my workstation.


The DirectX shaders of Ben Cloward don’t work on my workstation.