Tutorial - Changing the default start options

I hope this is the right place to post this. If not maybe somebody can move it to the correct category. This is a quick tutorial on how to change some start options in Zbrush. Enjoy!

I have posted this tutorial on my blog along with pretty pictures, too.


<b>ZBrush – Changing default start options</b>
   With version 3.5 came some new features that changed the way ZBrush launches and how it sets up your default document. You are now presented with an integrated file browser called the Lightbox that features object previews. In addition ZBrush now starts with a default document that has a polysphere in the center of the canvas.
   Often times when I see new software updates I am just flabbergast with the new amounts of features. Other times when I spot new features my first reaction is: “Cool, now where do I turn <b>that</b> off?” (which reminds me of the Viewcube introduced back in Maya 8).
   I really don’t need the Lightbox to pop up during startup and I rarely ever need a polysphere right from the get-go. In addition that polysphere also overwrites the default document which you could tweak in previous ZBrush versions.

So let’s see how we can go about to disable these features.

   <b>1.</b><b>Disabling the Light Box</b>
 Here is a simple one. Uncheck “Preferences-&gt;Lightbox-&gt;Open at Launch”.

   <b>2.</b><b>Get rid of the Sphere during start up</b>
 You need to open up DefaultZscript.txt which can be found in your Zbrush install folder under …INSTALLPATH\zscripts. You can use Notepad or any word processing software to open up the file. In the script file look for the following line:
    Go to the beginning of the line and add two forward slashes to comment it out like so:
   When you launch ZBrush now, it will no longer create a Polysphere by default.
   <b>3.</b><b>Restoring the Classic Boot Screen</b>
 This is optional, but if you liked the old boot screen from version 3.1 here is how you can get it back. Once again you need to edit the default Zscript in …INSTALLPATH\zscripts\defaultZscript.txt.
   Look for the following line:
     Now uncomment the line by deleting the two backslashes at the beginning of the line like so:
   Restart ZBrush and you should get the classic Boot screen again.

   <b>4.</b><b>Changing size of the default document</b>
 Depending on your monitor size and resolution the default document might be too small when you launch ZBrush. In order to change this you need to have the polysphere document disabled as described above.
   Launch ZBrush and go to Document in the menu bar. Change the resolution to something close to your desktop resolution (I use 1000x750). The numbers represent pixels and you can untick the “Pro” button to disable “Constrain Proportions” (and I thought it stood for professional, duh!).
    Now you need to save the document (Document-&gt;Save as) under …INSTALLPATH\ZDocs and name the file StartupDocument.ZBR.

   <b>5.</b><b>Disabling the background gradient</b>
 Personally I am not a big fan of the gradient background color that Zbrush defaults to. I rather use a flat dark grey (around 80% black). Here is how you do it:
   -To get rid of the background gradient go to Color in the menu bar, select main color and pick any color you like.
 -Now go to Document and click on “back” to fill the background with the color that you picked.
 -Next take the “Range” slider right underneath and dial it to zero to disable the background gradient.
 -Now all you need to do is save this under “Preferences-&gt;Config-&gt;Store Config” and the gradient is gone forever.

Cool tips and that being your 1st post is most appreciated. Curious to know if you have any idea as to how I can change what the Title bar displays. It appears to be showing my reg key in brackets and “by Ofer Alon” next to it.

I have seen where people have their names placed in the title bar and always wondered how they did that.


Thanks for the kind words.
And no, I do not know how to change the content of the title bar. I looked through all the options in Zbrush and couldn’t find anything. My guess is that you would have to edit one of the configuration files in the install folder. Sorry I can’t be of much help in this case.

the key at the top isn’t your reg key. It’s just a random number…Aurick said what it was in a post right after 3.5 came out.

Yep, I had to double check the key after I posted. I knew that I had made a mistake, but don’t have my reg key memorized.

I guess that it’s not really an issue to have my name on the title bar, but I figured that if I owned the proggy then I should be able to customize it as I see fit, right?

One thing that I forgot to mention is that, if you save a start up document and you wish to share a z-script, you will have to include a copy of your start up doc with the script in order for someone to use it. Something that Aurick mentioned in response to my post about changing the start up document size to open at that resolution.


Champion! Geez thats been bugging me for ages! :+1: :+1: :+1:

Thank’s so much, Count !!! That sphere has been driving me crazy…haha

I’ve tried the “lightbox” trick too… it just wouldn’t work for me and kept coming back (win7, 64bit…don’t know if it makes a difference)

To keep the Lightbox turned off, I had to turn it off in Pref’s like you said, then go to Pref/Config, and hit the “Store Config” button…

Now it’s gone at start up too.

Thank’s again !!! :smiley:

Just wanted to add a tip to an already great list of tips.

In Zbrush 3.5R3, there’s a button at the bottom of the Document menu>Save As Startup Doc, which will save the StartupDocument.ZBR to the correct folder for you.

Thank you.
My short video.

Quick Change background color(Using Render Fog and Fog Color 2 button)

Thank you for the tip.

Resurrecting this necro thread…

I’ve tried the tip to change the background, but whenever I choose New Document, the background changes to a lighter grey then the I saved in the config file. How can this be? I’ve also saved a new startup document with the darker grey, but it still goes to a lighter grey whenever I choose New Document…



How to remove permanently the gradient

when I create a new document the Back Ground Color changes to Light Grey!
is there a way to change the default Document Back Ground Color?
thanks guys

Anyone knows how to prevent zbrush from launching kinda full screen and stupidly covering start bar? I have no idea who would like to want it.

In Zbrush 4R8 there is some annoying home page with promo crap. How can we disable it?

“In Zbrush 4R8 there is some annoying home page with promo crap. How can we disable it?”

In ZBrush apps folder go to ZScripts folder, find “DefaultZScripts.txt” and rename it to examples: “Mute-DefaultZScripts.txt or *DefaultZScripts.txt”.

Anyone knows how can I change the default Mask, Smooth, Clip Brushes?

e.g. Currently, its set to ‘MaskPen’, ‘Smooth’ and ‘SelectRect’ but I would like it to start with ‘Mask Lasso’ & ‘Smooth Directional’ brushes instead?

So I’ve go the gradient to go away and when I store config. it does not save that part. I have to keep changing the gradient back to solid every time I open zbrush. I’m on the newest build of zbrush 2020.1. Any help would be appreciated. I hate the gradient.

Hey there , I have the same problem. I hate the gradient too.
The closest I could get is to save the document with no gradient under Document> Save as Startup Document and then Open it as soon as I launch Zbrush.

Still too many steps, seems incredible that there is not a more convenient way to disable it.
If anyone has any solution it would be great,