Rendering ZBrush Displacement-Maps In External Renderers (May 9th: 2nd file added)

Since no one has tried Max6+MentalRay yet, here is the best I could do. Can’t really do anything about the banding like I can with Vray unfortunately (like lowering the blur setting in the material editor). Mental Ray in Max seems to ignore those settings, so I figure the default 1.0 blur is being applied and can’t be changed. Playing with the various dispalcement settings can mitigate it some what, but also tends to make for a lower quality displacement at the same time (looks less like banding and more like a bumpy orange skin). No big deal to me though, since I don’t really use MR for anything at the moment. :stuck_out_tongue:

PS: Yeah, could be considered a failure I suppose. Figured I’d post it here anyways though so that no one got mad at Zbrush when trying to use it, hehe. :wink:

-subtract 0,627 from that value … this seems to be necessary because “no displacement” does not seem to be 0,5 in the provided texture, but 0,627 instead

This is important, why this value rray how did you derive it ?

Another vray test.

The displacement values here are

13.344 with -6.672 shift

These values are based on the displacment value given by pixolator and the autoscale value in the OBJ (use a text editor to open the file, it is in the header), there should be no need to guess this. I’ll put up a zscript/maxscript combination to do all this automatically once I have put a simple interface on it.

pooverfish!!! Hows the weather over there in Aussi! :slight_smile: Its me Eugene at Frantic Films :slight_smile: Everybody in 3d is trying to figure out the right way of doing this :slight_smile: mabe yah can help us out again :slight_smile: we got PRman and Vray up and ready. nice seenin yeah again.

Hey man, good to see you here :slight_smile:

The weather is a damn site better than where you are, cooling down a bit although it was 32c the other day.

Not sure what the prman settings are, but the scripts I have should make it a snap to get the values right, at least with vray. The prman stuff should also be done by numbers.

I’ll get them out this weekend and let you know.


Pooverfish: Your scripts sound interesting, looking forward to them to make life a little bit simpler, hehe. Not fussy so I used a guesstimate for mine and was very close (basically just eyeballed it). Amount=+14 Shift=-7 :wink:

how did u find out abt the value for alpha gain ? 14… thats pretty darn high from the suppose 0.8

.834 / .0625 not sure if thats the right way to do it but that gives the value :stuck_out_tongue:


I just went with trial and error having experienced the fact the alpha gain value will increase the displacment I pumped it up and kept the offset locked at 1/2 that value. I then work my way down to a suitabkle render always keeping the offset and the gain proportinally locked.
Otherwise the model will “bloat”

Trial and error : )


Here`s my test for Mental Ray, I imported poly to maya rotated 90 degrees and scale to about .4
reason being is zbrush import/exports defaults on 4 so in my scene the object was too larger

then I converted to a subd surf and added a subd approx node, I don`t understand why all these tuts and all these people use a disp approx since to all my testing whenever u use a surf approx or a subd approx node it overrides it.
my settings where something like
1 to 4

approx rendertime 40 secs. with shadow maps and 2 other surfaces

Ok heres a maya default renderer test
same procedure as above just no surf approx setting, the only setting that changes is feature displacement is off and sample rate is 32 and 16 accordingly, guys one more thing make sure u have wrap u and wrap v off and maya has a default filter for all textures if u leave it on ull loose some details in your map so just set it to 0
RenderTime 16 secs… :stuck_out_tongue:

squeige: Lot’s of banding in that last one. I take it this is Maya your using? So now I’ve seen this phenomena in two apps other than Max. I don’t feel so bad anymore, lol. Nice to know I’m not alone hehe. :wink:

after testing the matter i found out its my bump map making all that banding, seems mayas default renderer sucks at bump mapping creates the banding effect, referred to as moire

For those experiencing stepping in the displacment map when using max and mental ray: try resaving the image as a 16bit RGB uncompressed tif file through photoshop.

If you check out the mental ray render messages it indicates that the .tif that came in the zip is not supported and it is passing the image as raw data: it looks like it converts it to an 8 bit format.

I resaved it to a tif format that it does support (as listed above) and it neither messaged that it was converting, nor rendered with the stepping that I was getting with the original tif.


Also, regarding converting from grayscale to RGB in photoshop: be aware that your colour profile settings may mean that the midpoint gray of the original grayscale image is converted to something other than 0.5, with the defaults I had it was visually darker and a -0.5 offset with the same displacement values used for vray was not rendering the same result in mental ray.

Once I had fixed my photoshop colour settings it then worked just fine.


That seems to fix it :slight_smile: converting to rgb though seems to change the neutral gray had to set the offset in max to -0.58

edit: nm you posted again :wink:

saludos…aqui va mi experiencia con lightwave 7.5

Hehe, just saw your post after asking about Max/MR banding in the other thread. FWIW, resaving in PS still gives the “format not supported / converting to RAW” error, so there is still banding as a result. I also tried both 16-bit greyscale and 16-bit color versions saved in PNG format which MR doesn’t mind at all in Max, but still got identical banding to the uncompressed TIF. Like I said, not that big of a deal to me since I use Vray, but I’m curious and thought maybe I might be able to find a work around that could help folks stuck with MR. If only MR would obey changes to the blur setting like Vray does, then it would be problem solved most likely.

Edit: By the way, just thought I’d mention to all that if your renders (in any program) have a general mottled bumpiness in areas where it should be remaining smooth, then you more than likely are being bit by the banding gremlin too. I’ve found that certain settings can make clearly defined banding in one render, look like the bumpy surface of an orange peel in another (yes, the Lightwave post above mine prompted me to mention it). Converting to 8-bit instead of using 16-bit can do it for example. So can certain blur settings. Hoping this info helps you all get better renders in the future.

Here are my own results with Cinema 4D 8.5

I was able to almost completely eliminate the banding caused by C4D’s insistence on reading it as an 8 bit image. Here’s how:

Displacement Height 0.8 m
Texture Filter with SAT sampling at 2.5% Blur Offset and 2% Blur Scale. Contrast is set to 95%

No banding converting to 16-bit rgb tiff works i could swear i tried it before and got banding though tried so many different image formats. :stuck_out_tongue:

Rendered in 3dsmax with Mental Ray