Questions & Troubleshooting for ZBrush 4R8

This is a major issue spoke to a few people last night and they are having the same issue. Something is wrong with the 4r8 exe file when trying to apply shortcuts with a wacom device.

It have tested this with a mobile studio pro and the Wacom 27hd express key remote.

All other shortcuts work with other software just not 4R8…

GoZ doesn’t recognize modo 11 !!!

M i c h e l GoZ issue
GoZ doesn’t recognize modo 11 !!!

Working fine here …
Do you have the GoZ from Foundry installed? Because you need GoZ from your Foundry’s products page.

Thank You asecbrush

I’m really happy to see the beginning of a fully scalable UI for retina/hi-dpi displays.

This is relatively minor, but is there a way to change the UI font used by ZBrush? The current one is too fine for my eyes.

It would also be great if it could render at a retina/hi-dpi screen’s native resolution, but perhaps that is waiting for a later update (version 5?).

NWoolridge I’m really happy to see the beginning of a fully scalable UI for retina/hi-dpi displays.

This is relatively minor, but is there a way to change the UI font used by ZBrush? The current one is too fine for my eyes.


Pro4210 without a dark background it isn’t pleasing to the eye. Changing the color also doesn’t fix everything.

When you move the cursor there is a lot of clipping of the cursor icon going on in the direction you’re moving. It cuts 1/3rd from the cursor when you move at a normal speed. Because of this the cursor is even smaller and more unrecognizable. Also the cursor looks a bit aliased.

Anyone have the same issues? The clipping also happens on 1920x1200.

My specifications:
2x Intel Xeon E5-2696V3
Geforce 1080 GTX
Windows 10 Creators update

I’m having an issue in 4R8 where the default smooth brush barely has any effect on my mesh. Anyone else have this happen?

i re-installed multiple times and it has yielded the same result as above.
the workaround has been to make a duplicate of the standard brush and name it Standard1, then to put it into the zstartup/brush presets folder.
once zbrush loads- the default standard brush is the default loaded brush, but once you change to any brush, there’s still no using it again.
also- it seems that if you edit the standard brush (i.e. lower the Z intensity, turning RGB off), then saving the modified version of it to the zdata folder- it fundamentally screws something up and zbrush will then crash upon booting every time.

ZBrush 4R8 starts but the UI is not visible on the desktop. The cursor tracks everything properly because it changes to what is underneath it. I try to guess where the Restore button is in the upper right corner and click on it then the UI is visible in Window mode which I can then maximize and it’s OK. I have uninstalled ZBrush then re-installed it but it’s still the same. I updated my graphics drivers but it’s still the same.

Windows 7 Professional

What is your display resolution? Did you use the full installer from the web page or the auto update from 4R7? What happens if you delete or rename your C:\Users\Public\Public Documents\ZBrushData folder?

Not sure if its just me but the right click navigation now seems to only work with the secondary pen button (even though I currently have it set to middle mouse click)
The primary pen button closest to the tip of the pen (that I have set as the right mouse button) activates smoothing like I’m holding down shift. I hope there is a way of setting this back to normal.

I had shortcut and pen issues as well. I completely uninstall all pen drivers and reinstalled and everything worked.

another finding-

some time ago, Marcus_Civis kindly made a script for me, that gave me a large button for the “Solo” function, that didn’t have the dynamic feature on the button. this was his script:

[ISubPalette,“ZPlugin:My Buttons”]

[ISubPalette,“ZPlugin:My Buttons”]

[IButton,“ZPlugin:My Buttons: Solo”,“Solo Mode”,
,80 /width/, /image/,40 /height/]
//end button

the button in 4r8 is behaving oddly.
it still works- but only if you click on the button, but not touching the “solo” label.
when hovering over the label, i get a pop-up that says “select sheet” and if you should happen to click on the label, nothing happens.
no idea why this is happening. i checked the script from what Marcus had originally posted, to what’s currently installed in my 4R8 folder. i can see no differences.

issue resolved. turns out it was something on the UI that for whatever reason, i couldn’t remove. i rebuilt the custom UI and that took care of things.

Thank you sooo much for that tip. It felt very bloated to me in default.

Can anyone tell me how to make lightbox stick at one level instead of 3? No matter what I do (even storing the config) it wont stick.

Tried uninstalling and then reinstalling the wacom driver but its still forcing me to use the secondary pen button for navigation. If I cant fix it I guess I can just try and get used to it but it will be a problem on my surface tablet as it only has the one button

I tried uninstalling one more time and it worked. Also if anyone else is having this problem check the software specific settings in the wacom tablet properties

Preferences > Lightbox > Startup Rows > Store Config works for me.

Thanks Spyndel… I didnt even think to look there. DOH! lol You guys are awesome

I already had 3 crashes while scrubbing the inflate deformation slider on a simple dynameshed startup sphere. It happens randomly, but if you scrub it randomly a few times and maybe smooth or dynamesh the subtool in between the scrubs it will definitely crash.

*** Edit ***

I made a GIF of it. In the case below you see it crashing right after I did an undo and then tried to inflate again. I’m not 100% sure it’s because of the undo, because I also had crashes without undoing.

No problem. You can pay me back if you can help me figure out this Gizmo issue.

Issue: Gizmo vs Transpose functionality

First off, I love the new Gizmo, and it’s a big leap forward in Zbrush usability and the deformers are insane. HOWEVER, I was under the impression that it would replace the need for the transpose function, but I find myself having to toggle back and forth between the two modes in order to get all the effects Im after which is a bit fidgety.

Case in point, transpose mode has various context sensitive functions depending on whether it’s set to Move/Scale/Rotate. In scale mode, for instance, you can perform a scale extrusion from the anchor point by ctrl-dragging on the outermost inner circle. I haven’t been able to find an analogous Gizmo function for this–it doesn’t seem to be context sensitive to move or scale mode, and control dragging on the innermost scale control results in an inflation, not an extrusion. The ctrl-drag MOVE extrusion does work in Gizmo mode though, so it makes me think Im missing something.

I’ve tried ctrl/alt dragging on every Gizmo element to no avail. Am I missing something, or is this just an unfortunate limitation of the Gizmo feature?

Wow, great work
Big thanks !!!

But it feel it is massive slower at my Intel i7 2,6k + GForce GTX970 + SSD (HD C: with 180GB free)
Is it possible?

EDIT: I don’t know why - but it is running now fast like bevor now…