Questions & Troubleshooting for ZBrush 4R8

#1

This thread is for common questions and answers regarding ZBrush 4R8.

DO NOT USE THE AUTO [COLOR="#FFFFFF"]UPDATE SYSTEM TO UPGRADE TO 4R8. That system was not designed for an upgrade of this magnitude. Most of the issues that we have encountered have come from people skipping the instructions and just using Auto Update. If you did use Auto Update, please follow these steps before reporting any problems:

  1. Delete the ZBrush 4R8 folder. Because you used auto update, there won't be an uninstaller.
  2. Delete or rename your ZBrushData folder. On Windows it's in c:\Users\Public\Public Documents. On Mac it's in /Users/Shared.
  3. Disable your antivirus software. Many of those programs don't yet recognize ZBrush 4R8 and its components as safe.
  4. Download the full installer from https://pixologic.com/zbrush/downloadcenter/instructions/
  5. Install and Activate.
  6. Turn your antivirus software on again.
Thanks!

IMPORTANT: Due to the extreme popularity of ZBrush 4R8, we anticipate unusually long delays processing Support tickets. We will be working as quickly as we can to resolve them and working long hours to do so… To be on the safe side, please expect up to two business days to receive a reply instead of our usual record of replying within one business day. This Guide will help you better understand the Support system and help you get the best results in the shortest time.

Thank you for your patience! We are working as quickly as we can but there is simply no way to avoid delays at this time.

Launch time is always when we have the greatest number of questions combined with the fewest number of answers. It takes time to figure out what might be the cause of any given issue and provide a solution.

The initial post provides an FAQ which will be updated as necessary. If your issue/question is not found in the FAQ, please post it in a reply to this thread.

Thank you and Happy ZBrushing! :slight_smile:

FAQ:
Q: How do I get my serial number?
A: All releases in the ZBrush 4 series have used the same serial number. If you no longer have a record of yours, you can get it at the My Licenses page, where it will be listed as your License Key. If you have never logged into the My Licenses system before, you may need to register on that page. So long as you register using the same email address that your serial number is associated with, the page will then be able to display your serial number for you.

Q: Do I need to deactivate my current version?
A: While it is not necessary to deactivate your old version, it is recommended that you do so. In that case, please deactivate your current version before upgrading as waiting until after 4R8 has been activated will cause an error in your serial number that will create issues for you if you ever need to reinstall ZBrush.

Q: Why is the Auto Updater not recommended?
A: The auto updater was designed for smaller, incremental updates. With a major upgrade like 4R8, it can introduce problems due to the fact that it first makes a copy of your ZBrush 4R7 folder and then converts that copy to ZBrush 4R8. This means that you will have files left over for the 32-bit version even though one no longer exists. You also won’t have an uninstaller, which can create problems down the road. We strongly recommend that unless your internet connection is simply too slow for the full installer and you have no other way to download, you do not use the Auto Updater for this upgrade.

Q: Is there a 32-bit version?
A: No. 32-bit support for ZBrush has been discontinued. If you are one of the few people still using a 32-bit operating system, please do not upgrade from ZBrush 4R7. When you upgrade to a new computer, you will still be able to receive the ZBrush 4R8 upgrade at that time.

Q: What are the minimum OS versions that are required for ZBrush 4R8?
A: On Windows, ZBrush still requires Vista or above. On Mac OS X, the minimum required version is now 10.8.

Q: Do I need to upgrade KeyShot or the ZBrush to KeyShot Bridge?
A: No. Neither requires an upgrade at this time.

Q: Will installing 4R8 affect my custom UI?
A: You need to go to C:\Users\Public\Documents\ZBrushData\ZStartup (Windows) or /Users/Shared/ZBrushData/ZStartup (Mac) and rename your CustomUserInterface4R7.cfg file to CustomUserInterface4R8.cfg. Be warned that depending on the settings in that file, it may or may not work properly. Some UI’s can even break ZBrush so that it won’t launch at all. If you encounter issues with a UI that has been brought over from the previous version you will need to rebuild it from scratch.

Q: After using the Auto Updater, I get a message about a missing fxmodel64.dll
A: This is part of why the Auto Updater is NOT recommended. One solution is to copy that file from your ZBrush 4R7 folder. It’s in the main folder. If you encounter other errors, delete your ZBrush 4R8 folder and reinstall using the Full Installer. (You can’t uninstall 4R8 because the Auto Updater can’t create an UnIninstaller. You must actually delete the 4R8 folder.)

Q: After i get my activation code, ZBrush 4R8 won’t let me paste it into the window to complete activation.
A: This usually happens to people with high resolution displays. It is caused by your operating system scaling the ZBrush window, which is no longer a could idea since the ZBrush font now automatically scales with your Preferences >> Interface >> UI >> Buttons Size setting. If you have this issue, first make sure that ZBrush is allowed to control its own scaling. On Windows, that is done by right-clicking the desktop shortcut and choosing Properties. On the Compatibility tab, you’ll find a checkbox that affects DPI scaling.
Make sure that box IS checked, and that the combo box says “Application.” Save the setting. If this doesn’t resolve your issue, please uninstall ZBrush 4R8 and delete its folder. Disable any antivirus software that you have running. Install 4R8 again (using the full installer rather than Auto Update) and go through Web Activation again to generate a replacement activation code. The new code should work.

Q: How do I turn off the new IMM scrollbar above the canvas?
A: This feature has some nice functionality beyond simply providing another way to select from multi-content brushes. Please read the documentation linked to, above. If you do want to turn it off, make sure that a brush is selected that does NOT have multi-content. For example, the Standard brush. Then turn off Preferences >> IMM Viewer >> Auto Show/Hide. (Note: You can also change its position using the slider in that sub-palette. You might prefer to the left or right of the canvas, since most displays today are wider than they are high.) At this time, you cannot save the setting, so it will be lost when you restart ZBrush. One option is to edit your Default ZScript. Another option is to record a macro of changing the settings. You can then assign a hotkey to the macro’s button so that you can change the setting with a single keypress.

Q: ZBrush 4R8 Mac Version Live Boolean “Generate Mesh” Does Not Work
A: The Live Boolean > Make Boolean Mesh process is currently unavailable for users of OSX 10.9.5 (Mavericks). While the Live Boolean Preview works as it should, clicking the “Make Boolean Mesh” button won’t actually result in a mesh being created. We are investigating ways to fix this issue, but until such a solution can be implemented the only way to fully use the Live Boolean feature in ZBrush 4R8 would be to upgrade your Mac OSX to the latest version.

*While the ZBrush interface is now available in multiple languages, support continues to be in English, only.

#2

Installs but has problems

First round - Directory Already Exists error

Second time round - Installed, failed to launch. Checked directory, it’s there, but was missing a fmodex64.dll, proceeded to come up with many errors for “Unable To Save File” (missing directories perhaps?).

Found dll on web in order to allow launch and activation, in general though this installer seems broken.

Did you use the Full Installer or did you use the Upgrader from within the ZBrush 4R7 folder?

#3

can i keep R7 installed if i install R8 into a different hard drive location on the same computer?
For production reason , i can’ t to update immediately my projects from R7 to R8 and if anything goes wrong i will have to backup all my project for a possible revert to R7.

4R8 will default to installing in a different folder. You should not install it over 4R7.

It is recommended to deactivate 4R7 before installing 4R8 but not required. If you do not deactivate 4R7 before installing 4R8 then please never deactivate 4R7 as that will cause an error in the license.

#4

Subsequent launches appear to ask for activation again… (the launch page is quite nice though). Also not added to start menu under windows…

Did you use the Full Installer or did you use the Upgrader from within the ZBrush 4R7 folder?

#5

Copied in entire contents of previous zb folder (with skip on any newer files), now launches without save errosr, but came up with

SCRIPT: FBX-ExportImport_4R8.txt

ERROR: ZPlugin:FBX ExportImport:Options:Export Smoothing Levels IN: [|GetId, “ZPlugin:FPX EXportImport:Options:Export Smoothing Level”]

Did you use the Full Installer or did you use the Upgrader from within the ZBrush 4R7 folder?

#6

I used the ZPlugin->Auto Update->Check new updates command (before coming to the site). I’ll go and find where this full installed is located then…

This sort of thing is exactly why the release announcement said that the Auto Updater was not recommended. :slight_smile: Delete your ZBrush 4R8 folder, since another side effect of the Auto Updater is that it can’t create an uninstaller. Then follow the instructions here: https://pixologic.com/zbrush/downloadcenter/instructions/

#7

Ok all working now, thanks.

Two questions - Is it normal that the top most subtool is ignored/removed when using Live Boolean?

Holding Shift to snap to axis/alignment when drawing out tools no longer works, what’s the replacement (or is there a preference to bring it back, or is it a bug)?

#8

The request site kept erroring out after entering my serial and putting my info in. I selected the US option and kept getting an Opps error. Now I am locked out of my temps… I did send in a support ticket really wanted to try this out after staying for the 3hour demo :frowning: . Waiting on support at this point…

Update: I just received help thank you Pixologic!!!

The servers are truly getting slammed right now. We’re working on a solution to allow more download attempts but if you get the error that your limit has been reached there’s no option except to wait for a reply to the Support ticket.

#9

On the Upgrade to Zbrush 4r8 page it mentions using web deactivation however I only see manual deactivation. Will this work for installing 4r8 or am I missing something?

On a few ZBrush installations, the Web Deactivation button is not available. In that case, simply ignore that step.

#10

full upgrade (as suggested) everything went ok and activated but when I open app I get an error.

test.jpg

#11

Just so everyone is aware there seems to be an issue with Wacom or Zbrush 4r8 when you select the new app in the Wacom shortcut settings menu to add your shortcuts none of the shortcuts apply. Shortcuts only work for R8 when you apply them to the whole device vs select the new app from the program folder in Windows.

An I am referring to the new R8 app under Program files not under the x86 location so I am going to the right place. Either Wacom does not recognize the location or there is something wrong with the application. Not sure if this is a ticket item or not.

Has anyone else had this issue?

#12

It looks like the FBX ExportImport plugin still splits the UVs on every single face when the .fbx is exported. Is there a way to fix this?

Thanks!

#13

Any answer on the my two previous question?

#14

First of all: a big thank you to the entire pixologic crew and the beta testers.

But I have one minor problem with the 4.8 interface:

Windows 7 Pro
24" 1920x1200 Dell U2412M monitor
4095MB NVIDIA GeForce GTX 770 (EVGA) graphics card

the utmost top of the interface falls outside the monitor so I only seen half of it.
It is useable, but a little difficult.

I may send in a ticket, but I first want to be shure I cannot do something to change this.

#15

shot_170614_102520.png

#16

EDITED : My previous comment was wrong. :o

#17

did the full install.
migrated all my settings. everything is fine and dandy… except:
once i start zbrush the default brush that is loaded is the standard brush (as per usual).
if i change it to another brush, then try and click on and subsequently use the standard brush again- i can’t. it won’t change to the standard brush at all.
the brush icon just flickers for a brief second, then it goes back to whatever other brush i had been using.
i tried deleting the standard brush from the zdata folder and putting in previous versions of zbrush.
i either got the problem, or in one case, it made it so zbrush would crash upon loading and wouldn’t load at all, until i put back the faulty standard brush file from the install.
any ideas?

We only had one other user report this, and it was with ZBrush 4R7. We do not know what the cause was of the issue as it was so isolated and unable to be duplicated by us. I would recommend that you try uninstalling 4R8 and deleting its folder. Also delete (or rename) the C:\Users\Public\Public Documents\ZBrushData folder (or on Mac: /Users/Shared/ZBrushData). Make sure that your antivirus software is off, then install and activate again.

#18

When working with the new gizmo and when using the transpose tool it’s nearly impossible to locate the cursor position when it’s not hovering over a subtool. The background is colored very dark gray and the crosshair cursor is very small and colored black.

Could you fix it please?

I’m on 4k by the way.

#19

Yannick, does the background have to be darkgrey? Because you can set it to another color with the Document: Back button. Haven’t checked but have you looked at preferences, probably can customize colors.

#20

@ dfurlano

Did you first get a MSVCR120.dll error and then the Script:Sculpteo txt error?

If so I had the same thing happen.
I fixed it by installing the MSVCR120.dll file into the Windows/system32 folder and the Windows/sysWOW64 folder

Everything seems to work great now.
Hope this helps,
Escape