GoUVLayout - GoZ for UVLayout

Hello!

A new zscript I started working on yesterday! Still needs some polishing, but I should be able to release it next week.

//youtu.be/oi-AufylRPY

nice! :+1:

Hi Norman3D,

Nice you got it going for zbrush, I am using almost the same script in 3ds max for UV layout. If you could reuse the same code for TopoGun that would be top notch:-)

GoUVLayout.jpg

First version is available!

This plugin will allow you to send meshes to UVLayout and send them back.

Requirements:

  • UVLayout installed. (The plugin will automatically find it)

Installation:
Extract the ZStartup folder and replace it with the one in your Zbrush root folder.

Options:
You’ll find the GoUVLayout options under the Zplugin menu.

GoUVLayout_Options.jpg

DOWNLOAD

Hmm, wow, this sounds good. I honestly prefer UVLayout myself to built-in UV editors in most 3D apps, so this should come in handy, imo. Nice work on this. I’ll look into it over the weekend, and test things out.

Seems like this could be very handy. Unfortunately it’s not working here. When I press the button to send to UVLayout I see a command window pop up (too fast to read the contents) but then nothing happens, UVLayout does not launch.

Running Windows 7 64 bit here, in case that’s a factor.

Cheers,
Brian

Hey Brian!
Could you open the registry and go to:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uvl.File\shell\open\command

Could you confirm that this key does exist on your PC? The plugin gets the uvlayout path from here.

Hi! I don’t seem to have that, I have the .uvl, then inside that there’s the uvl.File and inside that ShellNew but nothing else inside that.

My license of UVLayout is activated by a USB dongle so that I can use it on multiple machines, perhaps that’s a factor?

Cheers,
Brian

Shouldn’t be a problem. That registry key is used to open uvl files with the uvlayout executable. Maybe you have an old version of uvlayout installed? Try repairing the installation.
Worst case scenario, you can create the registry key manually.
Just create the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uvl.File\shell\open\command

Make sure to change its default value. Here is how it should look like. (Make sure this path actually exists)

"C:\Program Files (x86)\headus UVLayout v2 Professional\claunch-uvlayout.exe" "%1"

Hmmm, thanks. I’m not familiar with changing things in my registry to be honest. I tried but it’s still not working. This is how things look in regedit. It does seem as if ZBrush is trying to launch UVlayout but it’s not working. The path does seem to be correct as if I type it into windows explorer it launches UVL alright.
I’ve just updated to the latest version of UVL but no change.

Cheers,
Brian

see this regedit path, not .uvl - finde uvl.File5992b84d965fbb2069e6f6c55ef4637f.jpg

yes! triar is right. You were showing the incorrect path.

This weekend I will change the plugin so that it asks you for the uvlayout folder in case it wasn’t found. The problem should be solved this way :wink:

This looks very interesting! Subscribed. :slight_smile:

Cheers!

34eb808b62160b06a0d0f637c23091bb.jpg my problem - if ZBrush is trying to launch UVlayout but it’s not working, From 3dsMax2010& 2012 work fine with uvpipe

Norman3D, windows 7 x64

hmmm triar, what version of Zbrush do you have installed?

I will look into these problems this weekend!

Thanks Triar, I checked that path in the registry and the entry is already there, just as in your screen shot but GoUVLayout still doesn’t work here. I deleted the incorrect one I had added earlier. Hopefully the newer version will fix this.

Cheers,
Brian

Norman3D,
i use ZBrush4r2b now, but in previous versions of Zbrush 4r2, this script does not work.

Best regards

ZB4R2b is the only version I’ve tried the script in here.

Cheers,
Brian

C:\Program Files (x86)\Pixologic\ZBrush 4R2\ZStartup\ZPlugs\GoUVLayout

C:\Program Files (x86)\Pixologic/ZBrush 4R2\ZStartup\ZPlugs\GoUVLayout - in my ZB4R2b…
808f8422a3a58c3992b6373e47cea133.jpg

Norman3d, muchas gracias !

a35db3027a5f9c8e3a2c25d00b558e87.jpg

What do you think, whether period or comma in the system to influence this process? Or maybe Eset ESS 4, anti-virus and firewall?

best regards,
triar

hi,

Is there and way to get it to work with ZR3?

Best
Daniel