GoMax for ZBrush 4

preferences>import/export>change the export settings to account for MAX’s Zup set up.

thanks for replys, guys.
but problem is why GoZ try to export all subtools in max instead of selected one with eye icon.

So on one hand it’s importing the legs, all though it should only export the upper part, right?

Do you have the “Subtools” checkbox in GoMax turned off? Try that, and let me know if it works.

The other problem seems that it’s being imported with the wrong rotation. Have you used GoZ and GoMax in the same session? I believe GoZ touches the Export Settings for the export/import, but doesn’t turn them back to the original state after the export/import is done.
I will have to double check this, and fix it.

Hi, Norman . Thanks for fast feedback.

turning off the “Subtools” checkbox in GoMax settings solved the problem.

and for second question.
Yes. If Goz was used for export in max, all zbrush settings in import\export preferences are turning off.
it would be nice if you be able to fix this. thanks

Hey Norman!

GoMax is great!

I have the same scaling issues with the Export (Zbrush4 to Max2011).
I used GoZ during the process. My scale in the Export (Zbrush) is set to 10,6074. While using GoMax the scale changes to 100 which makes my model super big.
Hope this helps a little for fixing the problem!

Keep up the good work!

You can disable the “Fix Scale” checkbox in GoMax settings. The “Fix Scale” checkbox, when activated makes sure that the export scale is always 100, instead some random number.

In the next version of ‘smooth groups import’ feature, please add
Thankfully being used.

but a final render material with correct settings would be cool too ^^

though … for vray and final render , you need a displacement modifier … in vray it’s the vraydisplacement mod and for final render it’s fr-MTD … ( I find final render faster and preserving more details ) … so is there any way to conveniently have these set with the right value ? maybe not a one click solution , though it would be nice … but something quick to setup …

by the way , my vraydisplacemod values seems to be based on the alpha depth ( or is it alpha gain ? gotta check ) from zbrush while final render seems to have fixed values for the displacement … ( which makes final render a whole lot easier to setup )

hope it helps improve gomax ^^

Hey, thanks for GoMax, its great plugin imo works better(faster) than Goz. Nice to see there is a version for zb4.
Thanks :slight_smile:

Heya

Great work ! Better than goz lol…

Anyway was wondering if that is possible… I got mesh in 3ds max > Export zbrush> Import BUT only textures ?

I dont want to replace mesh but only textures(bump/normal/etc) any chance to do it ? :slight_smile:

Vray support tooo plzzzzzzzzzzzzzz

HI again Norman3D,

IT would be super COOL. with Vray support…:+1: :+1: :+1:

best Daniel

it doesn’t work in Max 9.

it says Doscommand error.

Thanks for this, and another vote for Final Render MTD connection for displacement map :+1:

Fantastic! Thanks Norman, I was suffering withdrawals. :smiley:

just wanted to upload a working version of the smooth group import plugin for Zbrush 4 so hopefully it can get included as an option for GoMax.

Attachments

SmoothGroupImport_4.zip (223 KB)

Looking for a link in between Zbrush and max/vray as well.

It is just a drag to go through all the renderer settings everytime you send your model, AA, GI, samples, render elements, re-applying the materials …

I know an answer is model first, shader setup after … but come on, if you work in the industry you know how we are led to go back and forth in between both pretty usually.

Googling it would have been a faster answer but : yes, the last final render version is out now R3.5 SP3 (compatible with the once again disappointing Max 2012). Check cebas website for more info :wink:

First off, awesome tool! :+1:small_orange_diamond:+1:

I have a lot less issues with this over GoZ with max.

I have one suggestion though.

(Unless I am totally missing something) Could you add an option for the Max > zbrush workflow where material libraries are exported by default?

Currently matids/polygroups are not imported from max to zbrush because you have them turned off by default when the mesh is exported out of max.

Kind of a hassle to have to turn them on manually every time I wanna export something.

Thanks,

Attachments

mat.jpg

Also, it looks like the option to export polygroups from zbrush > max is grayed out? Why is that?

It appears the script is auto turning off “tool > export > grp” in zbrush which prevents polygroups from being exported out of zbrush.

Is it possible to turn this on?

Attachments

polygroup.jpg

grp.jpg

Hey E!
The reason why polygroup is grayed out is because I never got to implement support for polygroups.
Here is the “problem” with exporting polygroups from Zbrush to 3dsMax.
When you export your mesh with the polygroups, and import it in 3dsMax you will realize that the mesh has been split into pieces, different meshes. At this point the mesh is broken, the vertex IDs are renumbered and don’t match the original one, even if I merged them back together automatically.
There are a couple of ways around this, but it would not be pretty and only work some of the time.

As far as I know GoZ uses a whole different method. I’m simply exporting my mesh as an obj, whereas GoZ is exporting in a GoZ format, which is able to support polygroups nicely.

So, unfortunately GoMax won’t be supporting polygroups any time soon. You’ll have to use GoZ, which I’m sure will keep improving. Sorry. :confused:

Hi Norman3d,

Do you plan to update Gomax to work with Zbrush4R2?

I tried testing it with Max 2012 and Zbrush4R2 but can’t seem to make a connection. Hopefully this would be a minimal thing to fix.

Thank you