Dark's Brush Cycl0r - switch between you last brushes

here is my brush Cycl0r, you can use this script if you want do switch between 2 brushes again and again without typing every time the shourtcuts for the brushes…

how to install:
extract and put into you zstartup\zscripts folder or load manually via zscripts panel,
you will now find the script in the zplugin panel,
assign shortcut if you like…

when you use the Cycl0r there are two base brushs selected, activate another brush and use the Cycl0r again and u will switch the last brush you have used…

hope you like it…DarksBrushCycl0r.zip (1.92 KB)

Awesome Dude, like the script it helps a lot to my workflow. Cheers

thx :smiley:
i cant understand why zbrush dont has ths feature…

Hey - THX for this little script too… Pixologic should integrate that feature!

thx

AWESOME! Tried in R6 and works like a charm. Thank you very much for this darknesz. Its very useful.

the script is still working with 4R7!!
have fun

Curious if u could make a similar plugin that toggles between a selection of ya favorite brushes

ya its possible, which brushes would you have in this selection, and how big should be the selection of burshs??

Thanks for sharing!

just wanted to say i LOVE this script! i use the G key to switch between Move and a Custom Clay brush and can blaze through my daily sculpts! :+1:small_orange_diamond:+1:small_orange_diamond:+1:

hey,

I’m realy new to ZBrush and got a little trouble with this, maybe someone could help…
When I load the script and asign a hotkey with ctrl+alt, the last brush I used is the mask brush.
So everytime I use the script again it will automatically switch back to the masking brush.
I already tried to asign a hotkey in the textfiles in the Zbrush folders but this did not work. :cry:

Thanks for any help!

Hi folks,

does it still work in Zbrush 4R7 ?
there is no TXT file.
“Reload all Macros” doesn’t see it
and loading as a script has no effect, too…

Would be a great tool… today I was always switching between 2 brushes

Hi Alexx-- I can confirm it works great in R7, I’m about to test R8…

EDIT:
it mostly works in ZBrush 4R8… you can set a hotkey and it will toggle between your last two brushes, but it doesn’t seem to store those two brushes like it did in R7. i.e. I was able to store ClayBuildup and Move, and my hotkey would always return to those two, even if I use Dam Standard, Polish, etc. in between.

Hi,
it worked so wonderful in 4R7 but now in 4R8 always takes the Chisel3D brush, don’t know why ;-/
It’s a great script, have we a chance to get it back?
Thanks!
EDIT: But sometimes it works… I have still to find out what’s going on there… (it maybe hasn’t to do with that particular Chisel3D-brush)

Same issue as with AlexxCentral - a lways takes the Chisel3D brush.

Hoping for an update soon

hey guys sorry to hear that the script is not working for you please try this version of it.

DarksBrushCycl0r_ZB2018.zip (1.96 KB)

let me know if working or not.
have fun!

I also made a gumroad page for my cycler, its free and but if you like it, I would appreciate a small donation.

https://gum.co/LQHOzDarksBrushCycl0r_ZB2018.zip (1.96 KB)

That works for me now, thanks so much, really useful