ZModeler Inset Feature

Inset Polygon Feature ProblemHello everyone, I am a designer and character artist doing mostly jewelry now.

I have used zbrush on a daily basis for a couple of years now, and recently I have stumbled upon a very small, but annoying issue.

The inset polygon feature lacks one basic, but crucial option - to keep constant distance from the edges rather than scale the entire polygon inward proportionaly.

This minor change in functionality would be a huge improvement for my workflow - please add this option (for e.g. as a plugin).

I can’t be alone with this problem!

Thank you in advace - loyal user.

Indeed it would be a very valuable new feature to have.:smiley:

Just adding my voice(text) in support for whatever that’s worth.
<menu id=“userscript-search-by-image” type=“context”> <menuitem label=“Search Google with this image” icon=“data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAABHNCSVQICAgIfAhkiAAAAAlwSFlzAAAK6wAACusBgosNWgAAABx0RVh0U29mdHdhcmUAQWRvYmUgRmlyZXdvcmtzIENTNXG14zYAAAElSURBVDiNY/z//z8DJYCRkIKsthv/kRX9Z2BgmFalARdiIcaGKZXqcH5O+01U+ay2G3MYGBiSiXUmmofnsBDSjEUTMkiBe2Eq1JnZ7TcZBHhZGNythBl0lLkZODmYGX7++sdw/sZnhl3H3zF8+voHwwsYFkR5ijNICLMzTF31hOHnr38MHGxMDJlhMgwv3vxkWL7jJYpaJmzu0lTigWtmYGBg+PHrH8P0VU8YtJV5MNRiNYCfmxmuGQZ+/PrHwMmOqRyrAX///WfgYEOV4mBjwjAUpwHHL31iyA6XgRvCwcbEkBUmw3DuxmcMtVgDkYONicHLVoTBSJOXgYONieHHz38Ml+98Ydh88DXDtx//CBtACmBiYGCYS4H+OYyU5kasgUgKAADN8WLFzlj9rgAAAABJRU5ErkJggg==”></menuitem> </menu>

I too love the hell out of ZBrush, straight magic, but I, been tripped up and had to use workarounds with extra edges and planar scale etc. Particularly with stuff at the end of quad cylinders , rounded shapes turn to squares. I was under the impression that an insett is actuallywhat you described, an inset of x units from the existing poly border? It’s like it’s doing some sort of relax almost.

For single or region inset to an extent:
Step 1: extrude intended polygon(s) two levels
Step 2: perform an inward extrude (target polyloop) around the sides of your 1st extrusion made in Step 1
Step 3: perform an inset poly or region (whichever applies) on the originally selected polygon(s) from Step 1 as close as you can eyeball the same distance as the inward extrusion you performed in Step 2.
Step 4: qmesh (target polyloop) the outer ring of polygon(s) from the inset you just performed in Step 3 in the opposite direction of extrusions in step 1. if you are lucky you just trimmed off a ring of polygon(s)
Step 5: Select the remainder of the polygon(s) extruded in step 1 and qmesh Polygon(s) back towards the original surface until it snaps flush again.

here is a video demonstration of what I am talking about. Hackish and ugly and as you see in video not easy to actually match inset to extrusion, but it still works with an extra qmesh polyloop operation.

alternatively you can just perform steps 1 and 2, delete extruded polygon(s) and close the hole left behind if the geometry inside the inset doesn’t need to match, or in some cases you could bridge edges, but the 5 step method will work in many cases at least when relatively flat areas are being selected for the equidistant border inset.

Would save much time if you could check an option in the existing inset feature. If this feature ever does get added in an official manner… I would also suggest the option to have the inset snap if it’s about to deform from a perfect equidistant border.

if anyone wants to script the process to make it quicker… it’s experimental and not full proof, but go for it if you can streamline it, but please give me a copy of the script. Credit is always nice, but not necessary. mainly I just want to help if this ends up being useful for anyone else.

I noticed with insert loop you can use the shift modifier for “constant width”. I’d love to see that on inset faces when you have inset region enabled and press shift mid drag. The inset tool “square” function on shift doesnt work right now when inset region is on, so there’s room for it. Fingers crossed!

What is doing Zbrush is a not good implementation of the inset.
Image 847.pngImage 851.png
This is what Max does, that is OK in planar models but not in not planar
Image 848.pngImage 852.png
With the Miauu script Inset Pro with edge constrain active and with-wihout quads option and works the same with planar and not planar models. It keeps the same distances.

Image 849.pngImage 850.png

There is already a solution, you got the ctrl + inset and shift+inset in most case it works but there is also a solution when it doesnt work, just use the transpose master with scale if you control +clic one of the circle you can force a proportional inset.

I didn’t quite understand what you meant, care to do a few screenshots?