ZModeler EdgeLoop Partial issue

Hi there,

I am using ZBrush 2022.0.6 Version.
Is there any EdgeLoop Partial issue known?

May I overseen something, but I really have a hard time to figure out what it should be.
I want to just transpose two edges with the ZModeler tool.
Because it´s a wheel, I need to have it done in all five windows, so I switched symmetry on.
But that should not effect the EdgeLoop partial Operation.

So to tell ZBrush not to use the whole Loop, I gave any poly in the concerning area a different color.
But when I click one of the two edges in the center, ZBrush doesn´t care about and take any single time the whole bunch of edges, like a edgeloop complete.

I also use scale and move, doesn´t matter edge loop partial is not affected and the whole bunch of edges is used.

What is additional strange, it worked an operation before on a similar area without any problem. So I guessed it´s a bug.

But like almost I probably overseen something, so I won´t give the app the blame.

Thanks for explaination, if someone have a clue.

Hello @DarkStar ,

I’m not certain I understand the issue from the screenshots, but I can give you some general information.

The difference between Edge Loop and “Partial Edge Loop” varies with the topology, not polygroup. In cases of very simple topology the two options may not produce different results.

For a case like this where you only really need to select a few edges on each “spoke”, I recommend the following alternatives:

  1. ZModeler> Point> Crease> Shortest Path, followed by Masking> Mask by Feature> Crease.


  1. ZModeler> Edge > Mask > Edge. Simply click edge segment by edge segment the exact edges you want to isolate

After either of these, Ctrl-click in empty canvas space to invert the mask then activate Transpose mode.

If there are any issues with the symmetry of the mesh it can cause symmetrical low poly operations to fail. There may be minor variances between the points or the topology can simply be too low poly to work well. Make sure to force it into perfect symmetry with Geometry> Modify Topology> Mirror and Weld.


1 Like

Hey @Spyndel,

yes, may the screenshots aren´t so clear to understand like I thought.
Sorry for that.

If you have a look at 2nd pic, you might see the edge which is highlighted with the prompt “transpose edgeloop partial”.
That edge and the edge left of it are the edges of concerning, which I want to transpose.

So I took your 2nd advise and I have to say you hit the bullseye.
That is exactly what I have been looking for.

Actually I was looking for a command like that, like using in any other app, so just selecting an edge and using the shift button to adding others to it.
But that doesn´t work in ZBrush.

So I tried the edgeloop operation like a workaround.
To use the masking to do so, is even better, similar to selecting but in the ZBrush way.

Great to learn from you once again how to do it right.
You made my day, mate.
:+1: :+1: :+1: