Zbrush to Maya Displacement Workflow Tutorial

also imf_copy

in osx, it is located inside the maya application. find the application and right click it. you will see a list of options on of which is “show package contents”. imf_copy is located in contents, bin folder. change anything in any of vthese folders at your own peril. this is what makes maya work.

if you double-click imf_copy, terminal will open and spit out some data:

/Applications/Alias/maya7.0/Maya.app/Contents/bin/imf_copy; exit
image file copy and conversion utility for mental ray.
usage: /Applications/Alias/maya7.0/Maya.app/Contents/bin/imf_copy [-vegqfpLBrkx]] inimage outimage [outformat [outtype]]
/Applications/Alias/maya7.0/Maya.app/Contents/bin/imf_copy -c [-vgfr] inimage* outimage.map

-v verbose output
-e perform error diffusion
-g G gamma correction with exponent G, default 1.0
-q N if outformat is jpg: compression quality N=1…100
-f F if outformat is map: filter value F, default 1.0 (experimental)
-p if outformat is map: create filtered image pyramid
-L if outformat is map: output little-endian files
-B if outformat is map: output big-endian files
-r if outformat is map: use tiles (remap pixels)
-k K if outformat is exr: select compression algorithm:
K=none, piz, zip, rle, pxr24, default is rle
-c collate up to 20 images to pyramid map, largest first
-x N extract image N=0…19 of pyramid map, largest is 0
[Process completed]

this tells you everything you need to know, if you can understand it.
so you use this by typing in terminal:

/Applications/Alias/maya7.0/Maya.app/Contents/bin/imf_copy -v -p -L Documents/maya/projects/bird/091906/111306/111806/bird_repeltdisp.1001-R32.tif bird.map

so what’s going on here. the first bit-
tells it what application to run

the second bit-
-v -p -L
is a list of options for imf_copy, their meaning is listed in the little printout above. -v = verbose output -p = pyramid map -L = little endian file
little endian is a bit order

the third bit-
the file to converted

the fourth bit-
the output file name

notice the spaces, they are important.

by for now

You guys rock! Changes are now being permanently assimilated into my flow:

-The model is now NOT being put back together when coming back from ZBrush.
-The subD conversion has been kicked to the curb.
-I’ve lowered my own allowance, and I’m not surpassing 2048s.
-I’ll be flipping my texture files on export now, just as a precaution.

I only split her up so I can get between 3 to 5 million polys per section, so she’s got about 20 mil total. (ZBrush is like candy!) But on my next character I’m anxious to try your suggestion of the single-mesh-multi-map process all within ZBrush.

TIF is starting to be an acronym for “This Is Frustrating!” Coming right out of MD2, 32-bitters won’t import into Maya properly for me, which is one more reason why I’m so eager to try this newfangled imf_copy gizmo that all the kids are using these days. But I will lower my allowance here as well if necessary, sticking with 16-bit if I can’t generate my .map files.

I’m borderline hallucinating from staying up way too long 3 nights in a row trying to straighten this all out. Or is it 4 nights…? Anyway, it’s funny how clearly one can see, once someone has turned on a light. In a couple days I’ll post a pic or two to prove that all of your time has not been wasted helping me. Hopefully one day I’ll be able to return the goodwill to others as ignorant as I was, once, way back, back in the day… YESTERDAY, as a matter of fact! :lol:
Thank you all.

Hey folks

What about when rendering with maya’s default renderer or renderman?

Do i still need to convert to map files or i should use tiff?

Rest,the procedure is the same right?

Well, I’m a little embarrassed to admit this, but it turns out my mental ray problem is a result of some vague quirk on my machine here at home. When I bounce to and fro between Maya, Zbrush, Photoshop, etc, mental ray stops working when I come back to render in Maya. All I have to do is quit Maya and restart, then like magic it works fine. I’ve re-enacted this several times now to make sure, and there seems to be no mistaking it. So, I never ended up needing imf_copy after all, though I always love to learn as much as possible.

And thanks to all of your tips, I feel greatly satisfied with the results I’m getting for displacement maps. My models went from looking like melted candles to nearly perfect, with very good render times. So thank you all again!

Here’s 3 tests performed on the model’s head. Every part of her worked perfectly with the 32-bit TIFs from MD2, as tutored in the beginning of this thread – except for the head. First, some pinching around her nose that didn’t show up until now, so I went with subDs for this part of the model. Also, why the heck are there little spheres at the tips of her hair bundles? I’ve messed with it a bit, but no solutions or explanations have surfaced yet…


All together she renders in at around 3 minutes per frame. That works for me! :slight_smile:
Take care all, and I look forward to seeing more of everyone’s great work,



Very good matt looks like you character really came together.
Pixologic really is one of the biggest brain trusts in the industry I think its not the sculpting and making characters that is whats fun anymore. Its learning the harder complex things that software (Maya / Zbrush) can do. The stuff the average joe would give up on. Thats the exciting part of modeling.

Well to get the detail back you could dump MR and use Pixie or 3Delight export to these from Maya through Liquid. Join the world that Pixar made famous, you might find that you’ve been missing out… You could use Renderman as well, it’s been awhile for me. :wink:

Hi guys.

Glad that this helped some of you guys.

This method was taught to me by Scott Spencer himself. He is one of my teachers at Gnomon.

i tried using the convertfile.bat as stated in the directions , but nothing gets created when i drag my original zbrush output displacement onto it. i checked in directory where the displacement map was stored and nothing is there.

what am i doing wrong??

are you doing this on a MAC?

no im on a pc.

when i drag the file over to the convertfile.bat it just opens up what looks to be a command prompt for like 1 second - it goes too fast to see what it says.

ive even done a search on my machine for ‘.map’ files, and also a search for the file name of my displacement map to see if it got put somewhere else after dragging it on the converter

anyone know?


sorry just trying to narrow down the problem.

Have you tried it in different diectorys?

you could make a directory called map move the tifs to the directory with the convertafile.bat
in run windowtype

then cd map
convertfile.bat “name of map.tif” you should see what the msg is without quotes of course

Is the workflow different when creating displacements from Z3?
Does the multi-disp2 plug-in still work?
Is there a better way with Z3?


no, im using XP.

ive tried moving it to a different directory and putting the files also in that directory but it never worked.

hmm, i dont really understand what you are saying about running the cmd,etc.?

I got that problem too .
I ran the convertfile.bat and nothing happen . but I see that I lose 300meg space on my C: drive . but I can’t find the file maps .
pls help out .
I running too on XP

I’m gonna go for the easy answer first and say have you tried to do a search on your drive for files with a .map extension (in the search for files option)?

I can’t imagine there would be too many on your drive.


the files that you convert should be tiff . however some types of tifs dont work, so open up the image in photoshop and file > save as a tif with no layers.

that should fix it.

My tif file cannot be opened by Photoshop because it is an unsupported bit depth.
I cannot use imf_copy in the command prompt to convert the tif to map because it gives an error.
I cannot find the zbrush provided convertfile thing because the link in this thread does not work and the other thread provided by Aurick in another thread is dead.

How can I convert a tif to a map? Where is the Zbrush convertfile thing?

Thanks a bunch!

I’m on a mac and have just tryed the covert to .map but I cant find the file???

yes I did a search.

here’s what the terminal said:

mattphilip$ /Applications/Autodesk/maya8.5/Maya.app/Contents/bin/imf_copy -v -p -L /giantskined1001+R32.tif giantnew.map
MAIN .0 info : Copyright 1993-2006 mental images GmbH, Berlin, Germany. All rights reserved.
MAIN .0 info : imf_copy version 3.3.4
MAIN .0 info : version, 07 Nov 2006, revision 19515
0000000 IMG 0.0 info : opening “/giantskined1001+R32.tif” for reading
MAIN 0.0 info : /Applications/Autodesk/maya8.5/Maya.app/Contents/bin/imf_copy: /giantskined1001+R32.tif (2048 x 2048) --> giantnew.map
0000000 IMG 0.0 info : creating “giantnew.map”
0000000 IMG 0.0 info : format “map”, type “rgb_16”, 16 bits, 3 comps, size 2048 x 2048
0000000 IMG 0.0 progr: memory-mapping texture giantnew.map at 0x2008040
MAIN 0.0 progr: converting memory mapped image to little-endian format

if anyone can help me find te file or knows what happend Id love a little insight :frowning:

Hi mphilip

You can grab the ‘convert file’ .bat from here (last post on link):



does it work for mac? I was under the impression it was PC only

ok I know bat files are pc and I dont have maya on the pc thats why Im trying to do this though the terminal thanks though :slight_smile:

ok I found the map file un my user name… random