Zbrush Multi-Map exporter Broken?

I’m trying to use Multi-map exporter and export color textures. I have UDIMs so it should spit out a few tiles! But nothing is generated, even when I tried selecting the other options like normals or displacements. It worked before- what gives.

Now noticed the Textures are not being exported out but being saves over to the Texture palette for some reason. I have to export manually each one. :man_shrugging:

This is normal. The manual creation process requires you to clone a texture from the Texture Map menu TO the main Texture palette in order to export it. MME simply automates this process.

Multi Map Exporter works as expected for me. When you say “nothing is generated”, do you mean that the maps generated are blank, or that no files appear in the target folder you specified when clicking “create all maps”?

In the case of blank textures, have you first converted any applied textures to polypaint?

In the case of no image files appearing in the target location, the only way I was able to reproduce this was to attempt to use MME on a mesh with no UVs.

Are you certain Zbrush has permissions to write to the target folder?

Does this issue happen with any tool, or just the specific tool that you are using? Load the Polysphere.Ztl from the Lightbox tool directory. It comes with some UVs. You don’t have to do anything other than load it and enter edit mode. Enable Texture from Polypaint export in MME, and export it to the folder in question. It should produce a simple texture that looks like a white cross on a black background.

If nothing shows up in the target folder, there may be an issue with your hardware environment or with your Zbrush installation. You will need to contact Pixologic Support.

If you have no trouble exporting a texture from that tool, then the issue is likely with the tool you are using or your workflow. We would need more information about these to help you further.

At the moment, I’m manually saving out the texture maps to a folder. I’ve tried with other models too, and the same issue occures. It fails to generrate the maps and have them saved into a folder automatically. It happens with any map type (Normals, Color, OCC etc).
I’ve been using this Multi-Map for quite some time, so I’m familar with the way it should behave.

There is likely a problem with your installation, hardware environment, or with MME on your system configuration. Please contact Pixologic Support.

Good luck!

Thank you