Zbrush maximizing behind windows 10 taskbar

Hi,

When I lunch zbrush in windows 10 the windows is maximized but as soon as I open a project, Zbrush stays maximized but the bottom of the window appears behind the taskbar

Any idea how to fix that in Zbrush or windows?

Thank you!

A workaround would be to set the ZBrush window size so it’s above the taskbar. You can change the window size within ZBrush like this:

  1. In the Document palette, turn off the Pro button and set the Width and Height to what you want - for example for a screen res of 2560 x 1440 you might use 2560 x 1400.
  2. Hold ALT and click Resize. This resizes the whole ZBrush window.
  3. Press SHIFT+CTRL+i to store the configuration.

If you use this method then ZBrush will always start at this size but don’t minimize the ZBrush window as restoring it again will make it full screen. Use ALT+TAB to switch between applications.

You could also use a macro to set the screen size using the same method. That way you can quickly reset the size if you need to, just be pressing the button (or even using a hotkey). You could record your own macro, or edit the one below. It will need editing in Notepad so that the size is right for your screen resolution. Change the lines:

[ISet,Document:Width,2560]
[ISet,Document:Height,1400]

so that the width is the same as your screen width and the height is screen height less about 40 pixels.

HTH,

I have this problem too.
I didn’t WANT windows 10 and now it does this.

This needs a fix, not a workaround I think, I know its not Pixologic, but microsoft once again.

I guess I need to just sit down and reinstall windows 8 and then firewall microsoft so they cant do this again, these “updates” have nearly disabled my computer.

Another far less than ideal method is this:


  • Right click the taskbar and hit properties.
  • Then turn on “Automatically hide the taskbar in desktop mode”.

This has the disadvantage of the dammed thing popping up and down a lot for various reasons and driving you frigging nuts…

Here is troubleshooting of Pixologic Support.
https://support.pixologic.com/index.php?/Knowledgebase/Article/View/201/56/on-windows-10-the-taskbar-partly-covers-the-zbrush-interface

But, “Show if news updated” option is not found. :confused:

That’s actually for ZBrushCore. :wink: I think this issue should be addressed in the 4R8 update (or perhaps in a Windows 10 update - it affects other programs besides ZBrush). In the meantime, either set the Windows Taskbar to “autohide” or use the workarounds above.

ok.
I wait for the care by R8. (Maybe not cared by MS.)
Let’s use a StoreConfig method till then.

Yeah I also can;t find this “Show if news updated,”

Hey guys, I just fixed mine by adding this little shelf to the bottom. I forget how I added it, but I saw the “Expansion” arrows and hit that to move my brushes above the task bar.

Or perhaps ZBrush needs a “proper window”…

I always found the “full screen only” style, when maximized, a little weird…
Why there is no a normal window? In fact this is quite limiting, if you want to switch apps quickly using the taskbar…
The totally full screen mode should be a option imo, this is an app, not a game…

It goes full screen for a number of reasons, one is more space, another is that the taskbar is a distracting hinderence, and finally a lot of laptop monitors don’t show all the buttons if ZBrush isn’t full screen.
That just for starters.
This problem and others introduced by windoss ten have stopped me completely, I don’t draw, I don’t sculpt and I use a goddamed phone to look at zbc now.
When I have time, and another eight tb of disk space to backup and untrash what they did to my computer I’m reverting it back to window seven or eight, but frankly I don’t trust them any more so I’m much more likely to say screw it and switch to Linux.

It goes full screen for a number of reasons, one is more space, another is that the taskbar is a distracting hinderence, and finally a lot of laptop monitors don’t show all the buttons if ZBrush isn’t full screen.

Of course I’m aware of that, and that’s why I said it should be an option, because people have different needs, for instance, I don’t think the taskbar is distracting at all, and so on…

I hope Pix can do something about it…

Dispute the taskbar problem it has all the same buttons a normal windows window has, minimise, expand and kill. The only thing it hasn’t got is something it doesn’t need, a scroll bar. So what you are asking for is already there. If you want it to open at a different size that’s another issue, and it might actually already be possible using preferences, but how hard is it to either double click in the title bar, or to hit the other esize button?

Sorry about all the typos, I’m doing this on a phone and its reekey hard to fight off autocorrect at this size!

Im having this problem too using windows 10 :evil:small_orange_diamond:evil:

Hey guys,

I have been having this issue for a while on Windows 10 but I never really managed to solve it with the previously mentioned solutions.
Today I finally found a workaround that actually works for me on Windows 10 x64: after reading this article on howtogeek.com I installed a small application called TurboTop (that can be found here) that allows to set which application/window I want to stay on top.
This works pretty well for Zbrush: after installing the application you will find a small icon near the Windows clock on the lower right corner of the screen, where you can select/deselect which application/window you want to “stay on top”. Also bear in mind that even when Zbrush is set to be “on top” you can always visualize the Window taskbar pressing the window key (for example if you need to disable the stay on top for Zbrush).

The howtogeek.com article also suggest an alternative solution using an Autohotkey macro but I found that most of the key combination I tried interfere in some way with the application (probably is just matter to find the right hotkey combination).

I hope this helps. :wink:

The Windows Creators update fixed this issue…
So no more hacks needed… :slight_smile:

@Regnas:
How do I make THAT happen?
Im sick of this taskbar problem, it screws with EVERYTHING.

@MealeaYing:
Just do a regular update via Windows update, it should work…
In my case I did a fresh install of Win 10, I downloaded the Win 10 ISO from the microsoft website… :cool:

@Regnas
I dont understand, Windows 10 took away the ability to do manual updates, and forces them on me even when Im using cellular data. Its one of the many things that make me livid about it and one of the reasons Im switching to Linux when this computer dies.
How are you able to do manual updates?

@MealeaYing:

How are you able to do manual updates?

Well, I do it the old fashion, by formating the partition with my previous Win 10 installation and then I use the ISO to reinstall everything from scratch… Basically I’m switching the Operating system… It’s pretty quick, about 1 hour job… :smiley: