Zbrush 2021.6.2 smooth brush focal shift bug

Hi, recently our studio upgraded the Zbrush versions and I have something bothering me that I would like to know if we’re the only ones experiencing this problem. When changing the focal shift using the smooth brushes the slider goes either -100, 0 or +100 values, no matter if I use the spacebar hotkey or the slider on top of gui. Anyone else with this problem? Video demonstrating the issue: https://imgur.com/a/KES4DAi

Hello @JohnForthwind

Pressing Shift when you move certain sliders will change the slider behavior. This behavior varies with the slider. For instance if you hold down shift when adjusting the Draw Size slider, the slider will snap to integers, rather than the decimals of the default behavior. When holding down Shift for the Focal Shift slider, it will snap to -100, 0 or 100, since these are the most commonly desired values for that slider.

In the case of holding down Shift to adjust the Focal Shift for an active smoothing brush, simply reverse this. Release Shift after beginning to adjust the slider for the more gradual traditional behavior. As long as Shift was help down when you begin to move the slider, the adjustment will apply to the Smoothing brush.

Take Care!

1 Like

Honestly, don’t understand the reason to change into more finicky controls when it was working fine before, but thank you for the reply :slight_smile:

Yes, that happens because you keep holding shift when moving the slider.
I tried to do it using the O key (focalshift) but when holding shift, Zbrush do not recognize it as the hotkey to change the focal shift value then no slider is displayed.
the best would be to auto disable the sticky key when you change your draw settings using the quick menu.
so I also noticed that only Focal shift is affected (not draw size, Zintensity or rgb intensity) and changing the slider snap value in preferences do not change this behavior.

Hope it helps

Same here. The fact that I had to google this is the first sign that this is a bad idea. The fact that I literally said “what the ffffff?” out loud when I read it is the second sign.

I speak for everyone that agrees with me when I say: Don’t do that, Pixologic. That’s frakking dumb.

Also, when we want to go to “the most commonly desired values” for a slider, we type. But even without typing, snapping to the beginning or end of a slider is a useless thing, because those are easy places to get to as it is. So only the 0 provides any UX advantage.

Not sure what kind of dead drunk brainstorming brought them to code differently something that worked perfectly fine.

Thanks for the solution, even if it is annoying as… well, the rest of the ZBrush UI.

Don’t get me wrong, this is probably my favorite application of all time, but every time they announced that a new version was coming with major updates, I hoped that they finally found it in their hearts to build a UI that follows the standards of the OS it’s running on. I can’t imagine how much more efficient it would be.