ZAppLink Problem in 2018.1

Hi I was curious on how to fix a problem I’ve been experiencing in 2018.1. Whenever I try to use ZAppLink I get a window that says “Error encountered while attempting to launch external editor”. I’ve tried linking both Photoshop CC 2017 and 2018 but neither is successful.x.png

Attachments

x.png

I notice this problem too.

If you have this problem you need to download the installer again through My Licenses and re-install.

Yes, I submitted a help ticket and that’s exactly what I was told to do. Complete clean reinstall and now ZAppLink works!

Great :+1:

If I re-install ZBrush to solve the aforementioned issue of ZApplink failing to open PS, do all my custom settings for ZBrush need to be backed up (Ie. brushes, plugins, mats, stored configs, etc.)? Will everything be reset to initial “out-of-box” condition?

It is best to have a backup. A standard reinstallation (where you just uninstall and then reinstall) will typically not remove such files. But better safe than sorry. A full reinstallation (where you delete the ZBrush 2018 and the ZBrushData2018 folder after uninstalling) will certainly delete those files.

I have the same problem. I have 2018.1 installed. Is the current 2018.1 on https://pixologic.com/my-licenses/(last updated on 6-22-18) a different version? The previous install was from ZBrush_2018.1_Installer.exe and also last updated on 6-22-18.

If you have the problem you need to download again and re-install. It’s simply an update to the installer but will fix the ZAppLink issue. It was signed on 27 July 2018.

Thanks, Marcus. I reinstalled it, Zapp works, and my settings transferred.

So I re-installed but I am getting notes upon launching ZBrush:

2018-11-13.png2018-11-13 (1).png

ZAppLink now launches PS; however, PS closes shortly after.

How can this new issue be solved?

Update: The above goes away after running updater.exe, although I am again faced by the issue brought up by initial post in thread.

Update: Realized updater.exe is for legacy versions of ZBrush so I didn’t run after a CLEAN install. I don’t receive the notes like before but I do experience PS closing after ZAppLink launches it.

RexFut,

When doing a clean install, did you:

  1. Remove the Program Files\Pixologic\ZBrush 2018 folder after uninstalling? Sometimes some files/folders get left behind.
  2. Make sure you had the latest version by downloading from https://pixologic.com/my-licenses/.

Also, what version of Windows and what version of Photoshop are you using?

Thanks,

I am using CS6 on a Windows 10 system.

Here are the steps I took to remove installation:

  1. Uninstalled using uninstall.exe.
  2. Deleted pixologic directory from Program Files.
  3. Deleted pixologic key from registry HKEY_LOCAL_MACHINE.

After, I proceeded with the install. And yes, I installed using the latest install version via link suggestion.

Thanks for all your help. It is greatly appreciated.:slight_smile:

Hi RexFut,

Many thanks for the information.

Please try this:

  1. ZAppLink writes to a file called TempZAppLinkExport.psd which in a standard installation will be in the C:\Users\Public\Documents\ZBrushData2018\ZPluginData\ZAppLinkData\ folder. Try opening this file directly in Photoshop. This will show if it’s the file that is causing Photoshop to close.

  2. If the file opens OK then it may be a permissions issue. Check that your antivirus program is not stopping Photoshop open the file correctly. Also you can try setting both ZBrush and Photoshop to run as administrator. To do this, in Windows Explorer, right+click on the application executable (such as ZBrush.exe) and choose “Properties”. Then from the pop-up choose the “Compatibility” tab. Check the “Run this program as an administrator” check box. Then click OK.

Let me know if this helps.

Hi Guys, I have an issue with zapplink OS X zbrush 2018.1 and photoshop cc 2019. I have a pop up saying 'error encountered while attempting to launch external editor. I have pointed zbrush towards the photoshop app but it hasn’t worked. Any suggestions as I have tried suggestions in this thread.

ArtofGregg,

Post #3 should fix the problem you are having.