Xtractor Brush not working as intended

So I’ve used the Xtractor brush successfully a few times in the past. However, I seem to be failing horrible right now.

I checked out the documentation and even followed the steps for how to use the brush.

Basic overview. - Open mesh, ctrl click undo history so it’s white, sculpt details, select Xtractor drag rec, go to alpha panel and click “from brush”, the brush now turns blue (as it’s supposed to), however when I got to drag it out on the newly sculped detail the blue circle disappears and won’t drag out like it used to (before you could rotate the horizontal line in the blue circle to orient it. The only “alpha” that is generated is a simple flat grey one.

I tried all the Xtractor brushes with the same result, any ideas?

Edit I’ve also tested this with the regular XTractor brush and when I go to drag it on the model to capture the alpha, the blue circle is sort of “stuck” in the top left corner of my canvas even though I was clicking on the detail in the middle of the screen.

This seem to be a 2021.7 issue as it worked fine in 2021.6.6 I believe


Like I said on r/ZBrush, it works for me in 2021.7. However I did observe something that may indicate the issue you’re having.

When the Xtractor brush is activated the Stroke type is Dots. Works fine. Then when applying the alpha you can also use the Dots stroke but I also tried Drag Rect. Later, when I tried to Xtract again I saw the blue circle but couldn’t drag to grab the alpha. I realized I still had the Drag Rect stroke selected. Changing back to Dots stroke or Brush:Reset Current Brush fixed the issue.


No idea how I missed that…it works like a charm now, thanks!

1 Like