With non Matcap materials, why when I move an object the lights seem to move with it

I am a bit baffled by the lighting in Zbrush, I understand Matcaps and am not talking about those materials and their built in lighting.

When you position a light in the light pallet by dragging the dot on the sphere, how does the sphere relate to the world axis?

So for example if I put the dot at the center of the sphere am I putting it on the Z axis?

Also does having a texture turned affect the lighting I find that on one model when i do have the texture on one side always seems darker even though the actual texture map does not show this, Could a lighting difference some how be in the texture map even though I do not recognize it when I look at the map?


Hi @Zolly !

The lighting is static in relation to the viewport. The model however is not. Imagine the light placement sphere as a giant bubble with your model in the center. The bubble won’t change but the relationship of the mesh to the viewport can change.

Important points.

  • The interactive lighting only works with the Standard Materials in the viewport. You’re aware of the nature of Matcaps, but the Redshift materials won’t respond to all lighting in the viewport either.

  • If you’re speaking of the way lighting looks in a render, there could be light coming from many different features. I can’t speculate as to what might be active in your scene. For instance if rendering with Redshift there is a default panorama active in the Redshift rendering menu.

  • Materials may have material settings that affect the lighting of the model. Reflective materials may have image based lighting effects assigned to them in their material properties. These function independently of actual light source.

Try this. Restart ZBrush and load the dog ZPR. Make the Basic Material from the Standard Materials list active. Open the Lighting palette and move the ambient slider to zero. Then drag the active default light to the top of the sphere and give it a strong color like red or green to you can see the effect from it easily.

In the position the dog loads at, you should see those light effects hitting the top of the model. If however you rotate the model around in the viewport so it is legs up, the lighting is now hitting the underside of the model.

Now turn the intensity of the default light to zero but do not deactivate it. Look at the Standard material list again. Any material thumbnails shown there that are not completely dark have some sort of effect coming from the material.

Further information can be found here:



Thank you, Spyndel !