ZBrushCentral

Why doesn’t the objects dont appear on the scene together when i append it?

Basically in this process I am having trouble… and since a week couldn’t find where I am doing wrong

1- I created an avatar on daz and created the clothing in marvelous on it

2-after I completed the preparing the clothing for zbrush, I exported as obj

3-I opened the zbrush clicked import and imported the obj daz avatar

4-i clicked poly mesh 3d that star icon and imported the obj outfit

5-clicked on subtool, clicked on append and append the avatar that I imported on step 3

and when I drag, they don’t come on the canvas as together… only outfit obj comes on the surface

if you can let me know your thoughts on where I might doing wrong would be great
thanks!

Hello @pinarer

There are a few possibilities. First off, I would mention that it’s generally better to append a clothing subtool to a character subtool than vice versa. This is because characters tend to be symmetrical at least when in T pose, and clothing isn’t always.

Here are some things that could be going on:

  1. Make sure your desired tool has actually been appended. Does it show up in the subtool list for the active tool?

  2. Is the visibility (eyeball icon in the top right of each subtool entry) for both subtools on?

  3. Is Solo mode (Transform > Solo by default, but also on right side of default GUI) on? This will cause only the active subtool to display.

  4. Are the subtools sized and positioned correctly in relation to each other? Select the clothing subtool and press Frame (F) to fit the mesh to the viewport. Is it where it’s supposed to be in relation to the other subtool?

sorry for my many replies… to me looks like the size fine but there is some position issue in relation to each other. You can also see from the screen shots that i attached. jacket looks much higher then the avatar… so how can I fix the positions?

also an add to my previous to reply… I tried press Frame and took screen shots. so this is how it looks for each… may be there is some size issue? but I created the clothing on that avatar

Thank you very much for the reply. I actually even tried 2 ways… one like I mentioned and other one with plug in. The problem is, I see both obj on subtool but for some reason clothing obj don’t show up on the canvas. I attached a screen shot… I also checked the solo mode, no it wasn’t selected.

OK, a couple things.

  1. Unless using the Demo which is still currently at zb2018 as far as I know, be sure to upgrade to the most up to date version of Zbrush. It is free for registered users, and obsolete versions are not officially supported. I can’t help you if I have to factor in possible issues with an obsolete version.

  2. I suspect one tool may be drastically out of position in the worldspace, or drastically off scale from the other (one tool blocks the other from view when both are visible ), which is why you cant see them both at the same time in the viewport. This may have been caused by an improper export from the source program.



With both subtools visible, try switching on transparency + Ghost mode (bottom right edge of viewport edge or in the Transform menu.) If one tool is obscuring the other, you may be able to see the hidden one doing this.

Performing a Tool > Deformation > Unify operation on both tools in turn wont fix the mismatch problem, but if the tools are wildly off scale/position, it may make them both show up at the same time, solving that mystery.



I would try to re-import both of the tools from the source program in a different manner. There may be export settings that could fix the issue. The safest bet, however, is to import them both as part of the same file if that is possible, not separately. Zbrush can polygroup the meshes separately with Tool > Polygroups > Auto Groups, and then split them in the subtool palette into separate subtools.

Good luck!

Thank you very much for the reply again. I will subscribe after my trial ends… I tried ghost transparency but looks like it is not enabled, so I couldn’t click it and when I click the unity operation, nothing happened neither… so I will try to bring them both together and then split… lets see…

actually sorry adding to my previous reply when I clicked unity operation when the clothing selected under subtool… the jacket appears huge on the canvas… so looks like there is some sizing issue…

Yes, the Unify operation was not intended to fix your underlying problem if your meshes are out of position… It may very well make it worse. I’m just looking to find your missing meshes to verify what the problem may be.

The Unify operation re-scales the active subtool to fit inside the object preview window. If you perform this on both subtools in turn, and they are otherwise free of issues, you should see them both show up at the same time even if they are not sized properly.

If this works, it confirms for me that the issue is most likely a size/location mismatch between the two subtools in the worldspace.

1 Like

Hey Pinarer, you’re doing the bomber jacket tutorial from Travis Davids? Did you find a solution to the problem? Were you able to figure out why they weren’t appending properly and coming into the scene together?