ZBrushCentral

Weird glitch when exporting blender to ZBrush (flipped faces)

Hello, I am pretty much new with ZBrush, but had so experience with other software, and I cam across this weird glitch (flipped faces ?) when exporting Blender to ZBrush using Goz Addon

Do you have any idea what does that and how to solve it ? :thinking:
Strange thing : all the others objects I have impoted were perfectly fine, including the other leg which is almost the same…

Capture d’écran 2021-12-20 à 13.23.32

Hello @Kazrarr ,

The simplest explanation is that your geometry is flipped in the other program, but not apparent. Make sure to disable any double sided geometry visualization in your external program or to flip on Normal display so you can see what direction the normals are actually facing.

Otherwise, I would try to export/ import this mesh normally and see if it makes a difference. If the issue only happens when using your third party GoZ plugin, then you will need to contact the developer of that plugin. GoZ for Blender is neither developed or supported by Pixologic:

http://docs.pixologic.com/user-guide/zbrush-other-programs/goz/about-goz/

If the issue also happens when importing normally, make sure that the mesh geometry is free of non-manifold geometry issues. Remember also that ZBrush does not support Ngons. A polygon with greater than 4 points cannot exist any any time in ZBrush, and edges will be inserted to force quads and tris. If you leave this to be done during the import process, it’s possible that problematic connections could be made. It would be best to limit your export to only quads and tris.

Good luck!

1 Like

hello @Spyndel, thanks for your answer

I’ve first start by normally importing my object, but it did the same problem
Then check of any N-gon or weird geometry, but all was fine
Then I’ve flip the normals in the external program, and it did work when exporting, but the strange thing is that the normal were perfectly fine
so it solve the problem for ZBrush, but now I have normals going in the interior in my over software, which is a bit of an issue but I’ll find a solution for that.

Again : thanks for your answer and have a great day

Hello @Kazrarr ,

There is a preference setting in Preferences> Import that makes ZBrush flip the normals on Import. You may want to check that that is disabled. Likewise your external program may have export preferences active that affect this.

However, I don’t have any explanation for why only a portion of your mesh is having its normals flipped, and not all of it. My only guess here would be some sort of problematic aspect to that geometry.

If you have any UVs attached to that geometry you may want to delete them to check for issues related to those UVs.

Good luck!

Hey @Spyndel, I did check in the preference, and it is disabled, check my mesh in all the way I could, recreate it from my other object that were working, but nothing change…

I’ve found a solution for now, so I think I will not have anymore issues…

Have a good day

Hey I work with Blender and Zbrush a lot. Blender likes to mirror/flip the normals as well as the mesh when it does certain mirror operations like ctrl+m+(axis) and when using AutoMirror.
Before exporting to Zbrush, just make sure to select your entire mesh in Blender’s edit mode and go to Mesh>Normals>Recalculate Outside. It should be good to go every time
If some faces are still flipped, Blender might have gotten confused as to which faces should be flipped which way you can do the same process (Mesh>Normals) except click ‘Reset Vectors’ or ‘set from faces’.

1 Like