Weird artefacts in Vertex Color when exporting from zbrush in .fbx


I have an issue when trying to export an object with polypaint (vertex color) using .fbx exporter. It shows wrongly in 3ds max and behave crazy in Unity. If I do all my blenshapes in 3ds max and bake using Radiosity (which is not ideal for me) and export in .fbx, everything works and the vertex color displays correctly.

I am wondering if there is a hidden secret or option that could create this crazy effect from exporting out of Zbrush.

Thank you!


I forgot to add that if I export in Collada DAE from Zbrush the vertex color follows correctly. It is a workaround to the .FBX export but I would like to know why or if someone has an idea. Thanks!

Hello @Crussh

If using any version of ZBrush other than the most up to date version–currently 2021.1.2–please upgrade. You may be missing fixes otherwise.

There is a known issue in the current version associated with exporting from the FBX exporter in the Plugin menu. Please do the following instead:

  1. Close ZBrush.
  2. Reopen ZBrush, and load the file you wish to export from.
  3. Export your FBX from the main export function located at Tool > Export. The fbx options should be the same. Export only with this function, and do not first try to use the plugin exporter.

If this does not resolve your vertex color issue, please visit Pixologic Support and start a conversation. They will have the tools there to look into your issue in greater detail.

Good luck! :slightly_smiling_face:

Hi! @Spyndel

Thanks alot for your quick reply. It does work if I reboot zbrush and use the main exporter feature! Cheers!

Glad to hear it! A note–it isn’t necessary to close ZBrush whenever you want to export. You just don’t want to export after attempting to use the FBX exporter plugin in the same session.