Using Zbrush with Microsoft Surface Pro 7 Type cover

I can’t type precise negative values in the tool>deformation>inflate section because I can’t type the “minus” symbol when I’m in Zbrush. When I press the key it automatically types 6.
I’ve tried using ctrl, alt, etc…to no avail.
I can use the slider to get negative values but they’re not precise enough (I need -1, - 0.5, etc…)
Does anyone have an idea how to solve this issue, please?

Thank you :slight_smile:

Works for me (Win10, ZBrush 2021.6.6) using the numbers in the top row of the keyboard. Are you using a keyboard with a separate number pad? Perhaps a numlock issue. Sorry I can’t be of more help.

Hi @Forever_Ethereal, Welcome to ZBC!

Ctrl + click drag will directly snap to the -100, 0 or 100 so it doesn’t help for all sliders which stand in the deformation section.
But you have more control on slider which are floating point value and not integer. if you click on the top area of the slider the stepping is reduced so you can set a more precise value, but it doesn’t apply on inflate.

I won’t recommend you to increase the UI size as you are on a device with a limited resolution, but you can try to increase the size and see if that fit you more than right now.

Hope it helps,


No, I’m not using a numpad, just the Microsoft type cover.

I can’t even see any numlock key on this keyboard. I must be missing something but can’t figure out what atm.

Thanks anyway for your help.

Thanks for the information, Nicolas.

I’ll try the CTRL+click drag tip to see if it helps. If not, I think the best solution will be to invest in a separate numpad.


Well, I’ve just found out how to make it work…I didn’t use the type cover keyboard. I just turned on the numeric keypad and activated the Numlock option.
I can’t believe it was that simple.

Thank you again.

I’ve just found out that the numeric keypad is much more complete than the Microsoft type cover itself. And there’s a NumLock option there.

Works perfectly that way.

Thank you again.