ZBrushCentral

Unable to read subtool error!

Hi,

I get the following error when I load a ZBrush project file: “Unable to read a subtool and it will be replaced with a Polymesh3D”. It’s actually 3 error messages in a row, see file attached. It’s a project file with lot’s of layers, about 2.4 GB.
ZBrush version 2021.6.2

I’ve had a lot of Mem_Lock errors and corrrupted ZTools in the last year, and just upgraded my PC: Specs: CPU i9-10900K @ 3.70 GHz, 32 GB RAM, GeForce RTX 3040.
I was wondering if it could be a RAM issue (because that’s the one thing I did not increase)?

I’m also WFH, and uploading large files on TortoiseSVN using fiber broadband.

Any help or suggestions would be much appreciated ?

Kind regards

Stefan

Zbrush_Errors_UnableToReadSubTool_01

Hello @tortilla1 ,

This means the geometry in that subtool is corrupt and can’t be loaded. In the case of specific subtools that can’t load in a file that otherwise opens, I would suspect problematic geometry with those meshes, though files can corrupt for many reasons.

Load the most recent version of the file that can be loaded, and check every subtool in the file with Geometry> Mesh Integrity> Check Mesh. Meshes that report issues here should be fixed before saving the file again. If any meshes that report issues here also have layers, those layers will need to be baked or deleted. You don’t want any references to the geometry in a problematic state in the file.


There are many variables involved with uploading or downloading files over a network. Errors during the process are not uncommon. Make sure you are fully saving your files to your local machine first before attempting to move them to a network or cloud location. It is not recommended to open files directly from, or to save directly to a remote location from ZBrush.


Otherwise, if you have a copy of the file you can still open that contains the problematic tools and can’t spot any issues with them as I’ve described above, you can contact Pixologic Support and we can take a look to see if we can spot a problem. Technical support for ZBrush is not provided over the community Usage Questions forums.

Good luck!

Thanks for the advice, much appreciated !

Stefan