Transpose Line ccting like it has a hair trigger on it

Whenever I use the transpose line to duplicate a mesh, the mesh moves super fast even if i just move my mouse a little and I don’t seem to have that much control over where it goes. If I duplicate an object using the 3D Gizmo tool, that works just fine and the way it’s supposed too. Are there any settings for the transpose line that control how fast duplicated meshes move on the canvas?

Hello @joebuehrer

Pixologic is already aware of this issue. You will have to use the 3D Gizmo for now.