TposeMesh Bug - corrupted geometry

Hi while I was posing my character I ran into some sort of bug/problem.


I click on Transpose Master> tpose Mesh, I do the posing and after doing it strangely I lose the posing data. So to solve I export the model to obj, import it and do the same procedure as before but the result is what you can see in the last figure

Can you help me solve it. The goal is to pose all high poly without losing detail

Hello @Sky1

How are you posing the model? When you are using TM you are limited to tools that do not alter the topology or point order of the mesh. As mentioned in the Transpose Master Documentation this rules out using the Gizmo deformers because some of those will change the point order. You must use either ZSphere rigging or the Transpose Action Lines to pose the mesh.

Transpose Master needs a low resolution mesh to work well. The best results come from subtools that are in the form of a multi-resolution mesh with clean, low poly base topology and multiple levels of subdivision. The higher the polycount of the TPose mesh, the less reliable the process, performance, and results will be. TPM will create a new merged TPose mesh from the lowest available subdivision level for each of the subtools involved. If your source subtools don’t have a lower resolution base subdivision level to send as part of the TPose mesh, it must send the subtool at full resolution. If the TPose mesh is too high in polycount, the process may fail altogether.

Check all subtools involved for issues with Geometry> mesh Integrity> Check mesh. If you’re carrying around geometry that reports problems, this could cause issues for any operation that involves that geometry.

From your screenshot I can tell you that your mesh looks like it is problematically large in the ZBrush worldspace, which can cause issues.. Try to avoid using Transpose Master to make substantial changes to the scale of the mesh. It works best as a posing tool, not a transformational tool.

Finally, try to avoid working in a file that already has multiple TPose meshes loaded in the scene as this can sometimes cause issues.

If you cannot figure out where the problem is occurring, please contact Support to provide the file for examination.

Thank you!

1 Like

Hi, during the posing of the mesh I used the modifiers of the gizmo, mainly the bend curve.

I’ve tried decreasing the subtools geometry and creating a new clean project but nothing seems to work.

from what you wrote me at the beginning of the message during poinsing I shouldn’t use the editing tools of the gizmo because it could cause geometry problems, right? Don’t you think this is very limiting? Is there another way you know of to pose?