Symmetry - how to cause the brush to not affect the other side

The problem:

In symmetry sculpting mode, there are, in effect, two brushes - one on either side of the symmetry axis - each of these brushes influences not only its side of the symmetry but, if close enough, also the other. This causes them to work against each other. So, for example, if I try to use the move brush to move a large section of the geometry very close to the center axis, the geometry effectively “resists” being moved, and furthermore, it gets distorted between the influence of the two brushes.

The desired solution:

I’m wondering if anybody knows of a setting or a script that causes your brush to have no influence on the other side of the center axis when you are sculpting in symmetry mode.

If there is no existing solution then I hope this will be an effective call-out to the guys at Pixologic that this would be a very welcome feature.

Meanwhile, maybe one of you scripter’s would be interested in tackling the problem.

Hi @Francis_Bezooyen

It’s true that certain features, in certain situations, don’t work well when close to the center line with symmetry mode active. Generally speaking, if you want a feature to have no influence on the other side of the mesh, you would disable mirror symmetry. You can then work on one side of the mesh without concern for the other, and mirror the changes to the other side after you’re done working. This can be done with the Tool > Geometry> Modify Topology > Mirror and Weld feature.

Note that this feature only works in one direction, so in some situations you may first need to flip the mesh along the desired axis with Tool > Deformation > Mirror in order for the mesh to M&W along the axis in the correct direction.

Feature requests can be submitted to Pixologic via the Pixologic Support site.

Take Care! :slightly_smiling_face:

That option works in some situations, but it is not an appropriate solution in cases where the topology must not be changed. Of course, the smart-resym feature is good for those scenarios, but I am often working in situations where I have multiple objects combined into a single subtool and I had been operating under the assumption that the smart-resym feature would not work in that scenario. Gratefully, your comments pushed me to test that assumption. It seems like the kind of thing that I would have tested long before now. Perhaps I did and, at the time, it did not work, but as of the latest version at least,smart-resym does work with multiple meshes in a single subtool. So, that effectively resolves my problem, though I do think the solution I’ve suggested would be better overall. The main reason is that smart-resym can take a very long time to calculate on higher subdivision levels of a mesh.

I would like to submit this feature request but I have not been able to find out how to do that through the support site. Can you offer any clarification?