SubTool Master - Information, Installation and FAQ


Note: all plugins are now included with the ZBrush 4R7 installer. If you did not install a plugin then run the installer again.

For the latest information see the online docs here : http://docs.pixologic.com/user-guide/zbrush-plugins/

SubTool Master gives you greater control over your SubTools.

SubTool Master allows you to mirror, duplicate, merge, export all your subtools at once, fill all your subtools with color and/or materials and many other things!

:large_orange_diamond: This plugin is available with ZBrush 4R6.

:large_orange_diamond: Installation

The plugin is automatically installed with the standard installation of ZBrush.

:large_orange_diamond: Frequently Ask Questions

Q: I don’t see SubTool Master in the ZPlugin palette.
A: If you did a custom install of ZBrush then run the installer again and make sure you install the SubTool Master plugin.

© 2010 Pixologic, Inc. All rights reserved, Pixologic and the Pixologic logo, ZBrush, and the ZBrush logo are registered trademarks of Pixologic. Various patents pending. All other trademarks are the property of their respective owners.

Zscript Note: Interface item could not be found, Popup:Mir#3_eyeball In…, [IPress,[StrMerge, “PopUp:”,[Var,currentSubTool]]]

I get this error each time I try to run the mirror plugin. Please help.

Thank you,

I have just installed subtool master and an error pops up regardless of what i use from the plugin, e.g. merge, mirror, etc.

As an example, if i try to merge, the error is “zscript note: interface item could not be found. popup:mrg#1_PM3d_Sphere3D_1 in…[Ipress,[StrMerge, “PopUp:”,[Var, cloneName]]].”

The plugin is, i believe, installed correctly. I have no idea what might be causing this issue.

Thanks in advance.

Check that you have the right version. I installed the subtool master 1.2G with zBrush 4 and I got the same error as you. It workd perfectly after I installed the subtool master 4.03 version. Be sure to delete the old version.

This plugin does export all subTools at once, however it creats a separate Maya file for each subTool… I would like to work on my whole model back and forward between Zbrush and Maya. Am I missing something?

If you want to work in Maya and ZBrush use GoZ - see the ZBrush/Documentation folder and here:

Yes, GoZ is the way to go. I was making a mistake of not keeping Maya file open, so every time I used GoZ function it was creating a new file. So I had separate files for every subTool, I did not realize that if I have a maya file already open Zbrush sends my subTool there. My problem solved. Thank you for your post.

I’m getting an error as well with ZBrush 4 on mac. I have version 4.03b and installed a new one from the DL central.

What error? Can you show a screenshot?

This was like my error though it was fixed after a redownload of the plugin. I don’t know why it didn’t work before but glad it works now


Subtool Master plugin for 3.1 is still available for download ?
goes the one i found at the download center is for ZBrush 4 ;(

ZBrush 3.1 hasn’t been supported for years now. Is there a reason you haven’t upgraded to the current version?

Sorry I removed my post. My problem magically fixed itself…

Hi!i wanted to download sub tool master but there`s no download button, i can only download goZ

It’s included in ZBrush 4R6. So is GoZ. In fact, all officially-released plugins that are compatible with 4R6 are included with it. You don’t need to download and install any of the Pixologic plugins yourself.

I’m getting a similar error when trying to merge subtools.

ZScript Note: Interface item could not be found.
SCRIPT: SubToolMaster_4_07.txt

ERROR: Tool:SubTool:Uv
IN: [ISet, Tool:SubTool:Uv,1]

Any help in fixing this?


What version of ZBrush are you using?

Occasionally I have a problem when mirroring my subtools. I will make sure the subtool is selected and choose to mirror across the X axis and append it as a new subtool. I will see the screen flicker, it appears to mirror and when the model return I have a duplicate of a completely different subtool appended and there is no mirror of the selected one.

To work around this I typically hide all subtools but the one I want to mirror and that typically works but now I’ve come across a situation where even that wont work.

The results are deterministic enough that every time I attempt to mirror this subtool I get a copy of the same incorrect subtool every time.

Please let me know if you can help.

"I’m getting a similar error when trying to merge subtools.

ZScript Note: Interface item could not be found.
SCRIPT: SubToolMaster_4_07.txt

ERROR: Tool:SubTool:Uv
IN: [ISet, Tool:SubTool:Uv,1]

Any help in fixing this?


Same problem. I have it in both 4r6 and r7. The only workaround is to save and load the scene again.

I decided this problem. Just rename SubToolMaster.zsc in SubToolMaster.txt.