Second Life Sculpties in ZBrush - ZSculpty Tools (updated Aug 2021)

‘‘the achive is either in a uknown format or damaged’’

Try downloading again. I just tested and everything was fine.

Not sure if it has to do with the way the plugin makes hte polymesh but zsculpty has been rezzing min size sculpts that arent scaled when using sculpty-rezzer in secondlife.

Has anyone else had this problem? Any solutions? I should also mention im using the same zsculpty i did for zbrush3 so Im not sure if there is a zbrsuh4 version I didnt get.

^^ try scaling your mesh in Zbrush, it’s either too large for the sculpty rezzer or too small - I had that same issue when I was making objects that would hit the 10 m prim size limit so sculpty rezzer would just make them all .01x.01x.01 instead. Caused lots of headaches until I realised what was going on and scaled my mesh down (use the size deformation tool) I eventually setup a set of decently scaled subtools to work from rather than create from scratch every time and have this happen.

Doesn’t work with PolySphere.

The error message says “Please select a ZBrush Primitive and try again”.

PolySphere looks primitive to me, …but what do I know.

PolySphere demonstrates the same UV problem when creating a new texture with "New From Polypaint.

As mentioned previously, using UVMaster will make it all go away, but, if you then apply Spherical mapping (UV Map > Uvs), the problem will return.

If the problem reappears with internal UV mapping, is it the primitives, or something else?

The PolySphere isn’t a primitive. You need to start with the Sphere3D.

[Edit: the primitives are those shapes which have an ‘Initialize’ menu in the Tool palette. They are created using a math formula and have to be converted to a polymesh before sculpting.]

Alright, so I made a technical boo boo.
But that doesn’t really address my post.

The same problem exists in non-primitives, and therefore it is not fixed with your generous plugin.
(And I am referring only to Z4, as all the UV mapping worked fine in Z3.5.)

It would be nice if I could just make use of the default uv mapping (Cross) that comes with the PolySphere. Without enduring the inconsistencies of GoZ to clean this up in an external app.
UV Master is cool (and it fixes the problem), but I cant find a way to force it to conform to the default mapping on a Polysphere. If you select the “Use Existing Seams” button in UVMaster, you get a “Ballooned” Cross… close, but no cigar.

Perhaps there is another existing thread that discusses this issue on non-primitives that you could point me too. (This forum is getting big, and searching can take as much time a rebuilding the object instead)

I’m curious why a ballooned cross doesn’t work for your purpose. I understand the need to have the primitives fill the UV grid fully for a specific game requirement (sculpties in Second Life), but I’m unclear why the UV master version isn’t acceptable for your purposes. It even occurs to me that the balloon shape might result in less texture stretching, although I don’t have the experience to make that determination.

This is a client thing. They want a Si-Fi Planet with cross mapping and topology that matches. They seem to have a technical need for this type of mapping over others. I emailed them and they cannot accept a ballooned cross.
(A ballooned cross only uses slightly more pixels, and I cant think of any advantage it may offer)

I often prefer Cross over Spherical, as it eliminates poll pinching…but each has its own pros and cons.

Seemed like a no brainer for me to start with a polysphere, … and it would have been with Z3.5.

The problem with the UV’s are the same with the primitives…they exist slightly out of the bounds of the uv 1/1 space (I know there is a technical name for this, but I forget what it is). I took the sphere into MODO and shrunk it (the UV’s) down to 99.5 percent (need this only in the U direction but for consistancy I did it in both directions. Also I positioned it more squarely in the center to make it look neater :laughing: .

Its an easy fix, although an annoying extra step where it used to just work in previous editions of zbrush. I’ve uploaded the fixed ztl…hope its helpful.

Edit: by “shrunk it” I mean the uv’s not the sphere itself.PolySphere_1fixed.zip (345 KB)

I’ve updated the plugin so that there is a new button for scaling down the UVs of any polymesh. This will solve the problem of overlapping UVs in ZBrush if the UVs extend to the full 0-1 range.

Sweeeet! (ya know, the way Cartman says it)

Scale UV’s is just what I needed!

Thank you so much Marcus.
May the Breath of a Thousand Camels surround your enemies while they sleep.

And a big Dating Game Kiss to Nancyan for pinch hitting.


LOL! You’re welcome. :slight_smile:

I’ve updated the plugin to include sculpty map export and Collada file mesh export.

Marcus, thank you so much!! I decided to try opening one of my old sculpties made in ZBrush 3.5, which no longer worked in ZBrush 4. I turned off the texture made for it in 3.5, hit the “Scale UVs” button, and lo and behold I could create a texture from the polypaint for it once again in ZBrush 4. You made it possible to use my old work again from 3.5, and there is a lot of it!!

Doing a little happy dance!

Yay!! Thank you!!! Being on a Mac, I’ve never been able to export using the other sculpty exporter plugin. Can’t wait to try this out!


That’s great, I’m glad you find it useful. :slight_smile:

I just made a minor change to the sculpty export, so that the sculpty comes in to SL with the same aspect as in ZBrush. If anyone was one of the first 5 or so to download version 09 then they might want to download again to get the new version. You only need to replace the ZSC.

Thanks so much Marcus! This is great :)!!!:slight_smile: :slight_smile: :slight_smile: :slight_smile:

Edit (after installing): eeeeeeee! This is incredible. I can’t believe how feature-rich this plug-in is. It has EVERYTHING! :slight_smile:

Thanks BetD & Nancyan :slight_smile:

Small update (09b) to correct the prim initialization which gave the wrong output for some primitives…