Rotation unstable. Please help

I’m having a problem with rotation. Everything works fine until I rotate my model. Then when I go to edit or try to rotate again it jumps back and begins rotating from the previous location. If I try to edit it still jumps back to the location making modeling impossible. Please help I’m really looking forward to seeing what I can do.

Edit: It seems to work fine using my mouse and keyboard its when I’m using my touchscreen that the problem occurs.

When I initially start using Sculptris everything works fine. The problem occurs after rotating and sometimes it will work several times before failing.

Ive realized that what happens is as though my mouse button is locked (keep in mind Im not using a mouse but touch screen) so I guess you could say its as if my stylus doesnt leave the screen. For example, if I slide my finger rotating to the right side of my screen then lift my finger and touch on the left side my sculpt instantly changes to the rotation as if my stylus had swiped from the right to the left. It’s as if it doesnt release my touch?

Please if anyone has any ideas Id like to get this working.

Im using a Windows 10 tablet, Intel Z3537F cpu, fingers and capacitive stylus get the same results.

Also the problem only occurs during rotation. After rotating to my desired location when I start to sculpt the initial touch to the sculpt jumps to the rotation of sliding my stylus from the previous location to the new touch in the sculpt. Then I can sculpt and all sculpting works as it should though because of the rotation that occured getting to the sculpt I am now looking at the opposite side of the part Im working on.

Sorry I know its confusing. Imagine my frustration. Ive tried everything I can think of. I need a hero!

This is a long shot, especially seeing how old this thread is, but have you solved the issue at all?
Pixologic certainly haven’t as I’m having the exact same problem on my Lenovo Yoga 720.