ZBrushCentral

Ring Master! unofficial - Information, Installation

That got it Joseph.
Thanks
Brett

I created a ring in ringmaster. Set it to a size 7 with a thickness and width of 1.5mm square
create the basemesh.
Pulled out caliper master and measured the width in mm. It was astronomical ! Not sure what is going on. Tried it twice with the same result.
Can anyone give me a heads up on whats happening ?
thanks Caliper master measure.PNG

I have been trying to use ring master but am continuing to have problems with it.
After creating a ring base mesh I then try to smooth with increasing the subdivision levels and it wont engage any smoothing. (even on other things not created in Ring master.
I remove the plugin and everything starts working normally again.
This was the only 3rd party plugin I have installed when re testing this
Really disappointed

@Foxjaw: Sorry to hear about your troubles with this. As long as you press ‘Enter’ after typing in the desired values in the Ring Master it should generate the correct scale. ][-][4Z4R][)) here on ZBC is the author of Calipers Master he would have more information for you on how to get the transpose options setup there.

For the smoothing it could be related to having Dynamic Smoothing active. Inside of ZBrush if you just press ‘D’ it will active dynamic smoothing. This can visually be seen at [Tool:Geometry:Dynamic Subdiv] Having this active could possibly make your model appear as thou it is not smoothing.

The smoothing issue could also be related to creasing. By default the geometry created with the ring master plugin will generate creasing on the mesh. This will hold the edges and keep them harsh no matter how many times you smooth. You can disable this in the [ZPlugin:Ring Master:More Options:Creasing]

-Joseph

Thanks

Finally got it sorted.
Everything is working properly now

Is an 4R8 version coming? I tried the 4R7 version but the width segment doesn’t seem to work beyond 2.

i have a quick question. on the ring master demo, at one point boolean is used and substracts the forms desired. after when playing with the array settings with the gizmo, it creates shapes that are locked on the ring. my problem is when i move my move gizmo that is locked on mesh center, my array is moving in different positions. i know im missing something but i cannot figure it out.
kinda new to all this aswell.

Can I try the original version of RingMaster?

I moved the plugin folder for Ring Master 1.5 into the zbrush 2018 plugin folder and that is how I usually transfer it to newer versions of zbrush. This time I don’t see it in zbrush 2018. Is it not compatible? How to I get it to work in zbrush 2018? By the way, I love this plugin. Thanks for creating it.

Will there be a Ringmaster for Zbrush 2019?

Joseph or anybody that knows the answer… zbrush 2019 with latest Ringmaster.

After creating a ring basemesh, how do you go about getting the size scale that’s under Geometry to match the tool size? Transpose sees it right as does Transpose Master, but I can’t figure out how to get it to match in Geometry (I like using this as a quick-view reference for size).

There’s a scale setting under export that I tried setting to 1 per a video I found online but that didn’t seem to solve it either.

Love Ringmaster but the mismatch is really picking at my inability to let seemingly insignificant things go… :slight_smile:

Edit: Would love a simpler way but I just stumbled onto something.

After creating the ring base mesh.

1 - Set the Scale slider under Tool | Export to 1
2 - Save and close the project (this may not be necessary)
3 - Reopen the project, open Scale Master and Set Scene Scale
4 - I used the mandrel since it had a simple length of 50 - change the tool scale in Scale Master
5 - Ensure “All” is selected (this was on by default) and click “Resize Subtool”

Again, that may be a convoluted way of doing it, but it worked.

I got it to work in zbrush 2019.