Ring Master! unofficial - Information, Installation

Thanks Marcus, I use that script quite often, it’s a great one. It doesn’t work super great on these rings though sadly. :cry:

i have the new version 64bit on zbrush 4r7 P3. ring master keeps creating the wrong width size. i thought the zbrush is off but i checked with the 1mm cube and then in netfab and the zbrush scale is right. sometimes the US size is off too, but the width is always off.

@–E--: Perspective will be removed on next version :slight_smile: I don’t have any solutions for the shrinkage from low sides; using Creasing is going to be your best option but it is still going to shrink. I tried all my tricks (similar processes to the script Marcus posted) without luck. =<b>

@crispy1: Can you post what settings you are using to get the width to not calculate correctly? I’d be happy to take a look at it.

The width is most sound calculation in the plugin and should always be correct. To test: If the model was created with ‘Align Z’ active and you just export out the *.obj and then import that *obj straight into NetFab the width will be displayed as ‘Height.’ It should match the ‘width’ value from the plugin.

If the US Sizes are off that could 100% be related to the values I just selected. These can be modified to your liking by editing the RingSizes.txt


the settings I use are:

US size 7, thickness 2, width 4, I leave the other settings as the default. Align Z.
No matter how I change the width it will always give me a width of 7mm. I can see it’s way off even by looking at it.

The thing is, I get this same error only when I first start the app. After I tweak the settings a few times only then I get everything calculated right. So I need to play with the settings everytime I start it. It’s becoming a ritual now… maybe it needs a warm up first? :)))

@crispy1: I think I have a solution for ya :slight_smile: So are you typing in the value or using the slider? If you are typing the values make sure to hit ‘Enter’ on the keyboard after you type it in (ZBrush sliders occasionally do not update if you type them in and don’t hit enter.)

Let me know if that gets the width working correctly. I’ll look into seeing if I can bypass the ‘Enter’ somehow.


Thanks for the fast reply.
I used to type the values and hit enter everytime. I’ve tried now just the slider and surprinsigly it gets everything calculated perfectly, from the first time.
So I assume “Enter” is my issue. Actually I remember having the same issue with dynamesh res. a couple of times, not updating values even after pressing Enter, so I guess it’s a zbrush issue, not the app. Would be very greatful if you could make it to bypass Enter, cause the slider is not as precise as typing the exact values. But at least now I have a solution for my problem.
Thanks a lot

Just got this very useful…keep up the good work

errror.jpg Hi, I have just installed the plugin and I have this issue, the measures don’t match with I need, What should I do? thanks in advance .



All I can create is a cylinder and not a ring. What am I doing wrong?

Got it! Works great. Thanks.

@carlosmbernal: if you are typing in the values make sure to hit ‘Enter’ after you type the value in. (ZBrush sliders occasionally do not update if you type them in and don’t hit enter.)

Let me know if that fixes the problem you are seeing :slight_smile:


Thanks brotha your too generous! Love the improvements :smiley:

i just downloaded ring master and the toolbar is showing but the result is not a ring
please helpproblem.PNG


its very helpful for jewelry designers , good job !

Ring Master!
(Version 1.3 Updated 03/25/2016)
by: Joseph Drust

Ring Master allows you to quickly create Ring Band Basemeshes at a precise size for Jewelry creation

This plugin is unofficial.

Main features

  • Creates a Ring Band Basemesh at a precise mm size, thickness, and width
  • Exports out to scale via *.obj
  • Great for using with the ZModeler Brush and Dynamesh to create rings
  • No need for an external application to create a precise ring band for use in ZBrush.



Video Tutorial:


**** Make sure you have updated to ‘ZBrush 4R7 P3’ or later! *****

ZBrush 4R7 32bit:
UnZip the RingMaster_v1.3_x32.ZIP file to your \Pixologic\ZBrush 4R7\ZStartup\ZPlugs\ folder.
Restart ZBrush.
Ring Master will be located under the Zplugin tab.

ZBrush 4R7 64bit:
UnZip the RingMaster_v1.3_x32.ZIP file to your \Pixologic\ZBrush 4R7\ZStartup\ZPlugs64\ folder.
Restart ZBrush.
Ring Master will be located under the Zplugin tab.

**** Make sure you have updated to ‘ZBrush 4R7 P3’ or later! *****

*The plugin will create a new tool that contains a 1in(25.4mm) cube, a precise mandrel, and the ring band.
*Use *.ZTL when saving any created ring files (The creation process uses multiple tools to generate the band that can cause *.ZPR bloating.)
*As always, remember to save before using!

Change Log

v1.0: Initial GumRoad Public Release
v1.1: Added US Half Sizes, Increased MM values for creating Bracelets, Added Config options, Added Gem Stones
v1.2: Added the ability to align gemstones on the band. Added Array functionality, and Custom gem stones using InsertMesh Brushes. Thanks to @][-][4Z4R][)) for the recommendations and idea :slight_smile:
v1.3: Added the ability to create band with precise thickness from masking using the mandrel subtool. Fixed the Perspective issue reported. Added checking for ZBrush 4R7 P3. If you do not have P3 installed you will receive an error message now with information on how to fix.


Finally had some time to post this update :slight_smile: I added some Mandrel Processes that hopefully will be useful. This will allow you to create new ring bands by applying masking to the mandrel subtool. If you are not updated to ZBrush 4R7 P3 (or you are using a cracked copy of ZBrush…) this plugin will not work for you :slight_smile:

If you have already purchased Ring Master from GumRoad you should receive an email with a link to this updated version. Check your spam folders :slight_smile: Link my GumRoad site to download if you haven’t already purchased: https://gumroad.com/piggyson#
Any update may have issues; so if you run into any post them here and I’ll attempt to fix them :slight_smile:

Finally if you are looking for additional plugins dealing with scale inside of ZBrush check out Calipers Master by Fran Hazard: http://www.zbrushcentral.com/showthread.php?199136-Calipers-Master-v2-Real-size-measuring-tools-Unnoficial-Plugin



Wow, thank you for this update. This tool is getting better and better. Thank you. I wonder if you can consider placing some prongs, also a drill (for a later boolean substraction) with the stones… well, just an idea. Thank you for the update! :+1:

@Sflores: If you activate ‘Custom’ for the Gem Stones it will use the current InsertMesh brush you have selected. So if you create an IMM brush of Prongs and Drill Subtraction parts it will use those models instead. The Dimension (mm) slider will then scale the IMM in the longest dimension. :slight_smile:


I just downloaded and installed the latest version of Ringmaster.

i) For some reason it isn’t showing the Icon for the About/Splash Screen
And when I click on it, it just brings ups a blank dialog box

ii) When I set up the dimensions for a ring and hit “Create Ring Basemesh” I dont get anything.
The only thing that happens is that I can drag on the screen and it drags out a cylinder.

Can anyone tell me whats going on ? I’m wondering if there is some kind of glitch happening

THanks !

@Foxjaw: Can you check to see if the folder is extracted with it’s contents from the Zip file? (If the About image is not showing up it’s usually related to the plugin not finding the image in the RingMaster_4R7 folder. )

For the x64 version the install directory should be:

\ZBrush 4R7\ZStartup\ZPlugs64RingMaster_4R7_x64.zsc


Let me know if that helps :slight_smile: