Polygroups not exporting and importing into maya correctly

Haven’t done this in a while, but I was under the impression I could create polygroups, then export a single mesh as an OBJ with GRP turned on and when I import that same OBJ into Maya it would separate into separate meshes. This isn’t working though with the latest version of ZBrush 2021.7.1 (and Maya 2018.5).

I’ve also tried exporting as FBX with Export Polygroups as SSets turned on, but that only creates selection sets, not separate objects. I’ve tried it with Export Polygroups as Mats, and that works as well in Maya, but still leaves me having to split the model up in Maya. I was really hoping to just export from ZBrush and bring into Maya as separate objects. The GRP buttons used to do this as far as I remember.

I would prefer not to split the groups up in ZBrush, as I want to keep the higher subdivision level for my model and I’d lose that if I split them up (realize I could make a duplicate to keep this, but still).

I’ve also tried GoZ, but it’s the same thing, I just get selection sets.

Any help appreciated!

Hi Sean,

When importing an OBJ into Maya there is an option in the file dialog (when OBJ type is selected in the dropdown) under “File Type Specific Options” to import Multiple Objects. I think that will do what you want, though note that if a single polygroup is made up of separate bits in ZBrush it will be imported as separate objects.


Hi Marcus, and thanks for getting back to me, much appreciated. I have done that, but it brings in many more groups than are in the original object.
Here you can see what I’m talking about. If you (or anyone else) could test it on your end that would be amazing, just to be sure it’s a bug, in which case I can log it.
Again, this is using Maya 2018.5. And the same thing hapens if I turn on Legacy vertex ordering. It wouls seem strange that it would be an Import bug, which is why I’m thinking it might be a ZBrush Export thing since the Grp option was moved to the Preferences. (I’m using ZBrush 2021.7.1)


Thanks again,