Pinch brush not working as expected with brush modifier

Hey friends!

Im always using the PINCH brush a lot in early versions of Zbrush, in conjunction with brush modifier seted in 100%. The brush does the pinch , as expected, but with brush modifier in 100% he is not doing anymore the pull (or push, depending if the brush is ser to Add ou Sub) the mesh . This helps aton working in meshs with Lowpoly count because in can achieve a certain “definition” with edges without need to subdivide the mesh ! Great for early stages .

But this is not working like before. The brush is not more pushing or pulling the mesh together with the pinching when we set the brush modifier to 100% in ZBRUSH 2021.

Anyone knows how to fix it?

Thanks in advance

Hello @Rudse

Are you using the brush in Sculptris Pro mode? The Pinch brush is one of those brushes whose behavior changes somewhat in Sculptris Pro mode.

When the Sculptris Pro is not active, the brush makes edges by pulling geometry closely together–this can result in very sharp edges at the expense of distorting the surrounding geometry. With Sculptris Pro mode active, the brush actually inserts additional geometry to build the edge, but does not pull it as tightly together. Both versions of the brush are useful in different situations.

Hey Syndel, thank you for your time.

But what you described is exactly what im expecting to see using the brush, but this is not working in Zbrush 2021, and yes, Sculptris Pro model is not enable … im hopping to have that behaviour to make edges (with the geometry being pulled toghether ) plus the effect (setting the brush modifier to 100%) of this forming edge being moved in the same time by the outside or the inside of the geometry depending if we are adding or subtracting. Thats the way its was always worked in other versions , but its not working this way in Zbrush 2021.

The brush works as expected for me in 2021.


You may need to document your issue and illustrate what is happening and on what type of mesh you’re trying to use it.

If using a tablet, determine also if you have the problem when using the mouse, or if it’s only an issue when using the tablet. There are some known issues with 2021 and tablet performance.

I’m using the tablet, but the mouse is the same.
The video I posted shows the previous version of Zbrush (2020 1.4) with what should happen when we increase the brush modifier to 100%. It pulls the corner out while reinforcing the edge, but that doesn’t happen in Zbrush 2020, where it just reinforces the edge.

I don’t detect any difference here, Im sorry. However, I think I know where the confusion is coming in.

Read the ctrl mouseover description for the Brush Modifier control. It reads “For the Standard Brush the Brush Modifier slider effects the amount of pinch (if positive) or the amount of inflation (if negative). For all other brushes the Brush Modifier slider acts as elevation. The slider determines how much elevation the brush will add (if positive) or subtract (if negative).”

It could be mistaken, but there is no indication from the documentation that the Brush Modifier works with the Pinch Brush in any aspect other than elevation. It does, however, add a pinch effect to the standard brush. Is it possible you’re confusing the two?

Yes, I can confirm that it behaves differently in ZBrush 2021, but works normally in ZBrush 2020.1.4.

I would like to be confusing the two brushes (standard and pinch) :slight_smile: , but no.

I am talking about this elevation effect in the PINCH brush when we raise the brush modifier. In the video I have posted above, which is from a version prior to 2021, I show that I’m using the PINCH brush on the sphere, with brush modifier at 0, and then with the same PINCH, but increasing the brush modifier to 100, we can see the effect of elevation that I would like to use, however in Zbrush 2021, using the PINCH brush and setting the brush modifier to 100 we don’t get the elevation effect.

Sorry, you expressed the problem as a lack of pinching, not elevation. As you can see here, the Pinch brush still pinches as expected:


Where it might be differing is in the amount of elevation . I have no explanation for this, and no suggestion other than to contact Pixologic Support and ask them about the change if you can document it for them.

Yes, in this new version its like that we cant get any elevation (it’s not the amount, we just can’t get any).

I will try to reach out the support to see if they can help in a way to get around it.

Thank you anyway Syndel


Increasing Imbed Depth to around 50 will help.

2020-08-16 12_41_24-ZBrush

Thank you Zber2!

I’ve already using this “solution” , but it’s a little weird when we are trying to sub insted of add. But it’s definitely helping for now

Thank you my friend


Just use the Standard brush with 100% Brush mod for the pinch effect. I can detect no meaningful difference from the video you showed. It both pinches and elevates:


SOLVED - With the new update, version 2021.1, PINCH brush is working correctly with brush Modifier now.

Thanks everybody !