Pan / Zoom Problem with Wacom Intuos and 3D Pen and ZBrush

Hi all - hopefully someone can help with this it’s driving me nuts…

Have mapped one button on my wacom pen to ‘Right Click’ to tumble in the Viewport. Have mapped another to ‘Pan/Zoom’ in the wacom pen settings panel. The correct functionality for this is when I press the button and move/hover my pen over the tablet the viewport should pan - then if I press on the tablet while still holding the button and move the pen it should zoom. I’d say 90% of the time if I’m just panning - when I release the button the viewport randomly zooms in or zooms out - the actual zooming is erratic too - If I zoom in to where I want - and release the button - it randomly zooms to an arbitrary amount.

I have tried this on both the Pro Pen 2 and the new 3D Pen. Have tried having my mouse connected and disconnected. Wacom and Pen work perfectly with Blender 2.9, Adobe etc.
Have tried all the speed settings for Pan/Zoom. Windows 10, Wacom Driver and ZBrush all up to date.


I use right click navigation with the Intuos tablet and Pro Pen 2. CTRL-right click to zoom. When zooming if I release the CTRL key before the right click then the model snaps back to it’s state before zooming. If I release the right click before the CTRL-key then the zoom works as intended. The snap back usually happens when I’m working too fast or tired. Also when I’ve navigating with a very large model (> 20 M polys). I have to wait a fraction of a second for the display to catch up. Given that you say it works 90% of the time my thought is maybe to look closely at the order which you press and release buttons/keys/pen presses. Good luck.


Thanks for the reply - I know what you mean with regard to technique with the pen. I ended up setting each of the three buttons on the pen to Tumble, Pan and Zoom independently. It’s a bit better but panning still intermittently causes the viewport to zoom that is definitely not user error - I repeat the same pan gesture and 50% of the time it zooms either out or in randomly - can’t seem to find a pattern/logic to it. I have seen posts here in the past with the same problem. When I use the express keys on the tablet itself - it zooms, pans, and tumbles fine. Guess it could be a Wacom driver issue, pity - this is making me consider alternatives to a potential upgrade from Intuos to Cintiq.

Hi @Terekki

If you are on Windows, try disabling the “Tablet PC Input Service”. I know that causes conflicts with the Wacom drivers. Hope that helps.

1 Like