is there a way to Disable Toggle Mode on / off - Zbrush's Zadd & Zsub?


i assigned a keyboard shortcut to ZAdd and ZSub which is W and E
Reason for this keyboard assignment is that
first is i really dont like holding alt modifier for Zsub
second i am planning to make it similar workflow 2D program where W is always my Brush Tool
and E is eraser

now my problem in zbrush sometimes accidentally turned off Zadd / Zsub
because the way hotkey triggering is in cycle mode on / off

is there a way the cycling mode disabled ?
like when the Zadd or Zsub is already active it wont turn off by accidently hitting the hotkey

thanks !

You can do it with a couple of macros. Save the two files to the ZBrush 4R7\ZStartup\Macros\Misc\ folder and then press Macro>Reload All Macros or restart ZBrush. You should then have two new buttons in the Macro>Misc sub-palette called ZAdd and ZSub. Assign your hotkeys to these buttons. Each button only turns on ZAdd or ZSub.

hey that was fast , it was working great ! thank you for helping me out

You’re welcome. :slight_smile: