IMM Viewer doesn't appear (2021.7.1), what am I overlooking?

Hi gang!

First of all, (slightly) offtopic but has to be shared: ZBrush is awesome, even though I am still busy learning the basics I’ve already managed to do so much despite still being somewhat of a novice. For me ZBrush is the #1 ‘expansion’ for my Daz Studio endeaviours but I’ve also started to make progress stand alone (even expanded ZBrush with KeyShot (for ZB) which is also an awesome experience).

My actual question…

I followed this #AskZBrush YouTube video on how to make a tile patten, it explains about making an InsertMesh and then NanoMesh brush.

My question is about the moment at 8:20 in, the InsertMesh brush is created and ZBrush shows both the InsertMesh brush but also shows the IMM Viewer at the top. Whenever I repeat these steps with 2021.7.1 I do see the brush but I don’t get to see the IMM viewer on top.

I checked my preference setting (Preferences => Interface => IMM Viewer) but just to make sure I also renamed the “ZStartup” folder to force ZBrush to start in a pure vanilla state. But even in this state the InsertMesh brush shows up, but not the IMM viewer.

Despite the preference being set to default (Placement set to 1, and Auto show/hide is enabled).

I can’t help the feeling that I’m overlooking something obvious but can’t put my finger on it. Do you have any idea what could be happening here?

Here is what’s shown on my screen:

Thanks in advance for any possible feedback!

Hello @ShelLuser ,

The IMM viewer won’t show up in the program now unless the brush contains multiple meshes. If you append a second mesh to your brush it should appear.


Thanks for the feedback but unfortunately this doesn’t seem to work… if I follow the tutorial exactly, so including duplicating and then ‘re-merging’ the subtools, I get the exact same result:

The insert mesh brush is shown but the IMM viewer never pops up. As I mentioned above: this applies to my custom interface, but also happens whenever I reset everything back to default.

Does the viewer appear when you load any of the default IMM brushes? If not, then there is an issue related to either your installation, custom UI, custom preference settings, or display resolution. If it appears for those but not with the content you are working with then I would suspect an error in your process or an issue with the content.

Your UI looks atypical. Please note that to test issues related to a problem UI, it must not load with the program. Loading a problem UI and then switching may not clear all issues. Restore the default UI then store the configuration with Preferences> Config> Store Config, and restart the program.

Additionally, these are the default settings for the IMM viewer. Please revert these if they have changed in the program, store the config and restart.


Re: Screen res. Running ZBrush at a lower resolution than the recommended 1920 x 1080 may result in interface elements not being able to display properly. The complicated part here is that if your OS has any sort of display scaling active (for instance your display is set to scale content by 150% or 200%–common with high resolution displays) this actually reduces your effective resolution for the purpose of displaying ZBrush. In other words, if your display meets the screen resolution requirements but display scaling is active, this can effectively reduce your display below spec, and cause the same problems as attempting to run ZBrush on a much lower res display.

Otherwise, please contact Pixologic Support for technical issues with your ZBrush installation. If there is some sort of larger issue with your install, the community usage questions forums will probably not be able to help you.

Thank you!

1 Like

And now my inexperience shows because I wasn’t aware that there were any, learned something new here which I really appreciate (this is why I’m diving into those tutorials: to learn more about the basics).

I’m a little excited right now because I loaded the ‘IMM Curve’ brush, the IMM viewer did pop up and when I look at it and see things like “stiches” and “wood planks” I can only imagine what I can do with all that.

Yeah, I’m aware. Which is why I ended up renaming the actual “ZStartup” folder so that none of my custom settings would be used. However… I’ve only done this on my laptop, not my actual workstation (not at home right now). While my laptop does have the required resolution it also has its zoom setting to 120%.

Makes sense, yeah I can well imagine how this may become a bit too specific for the forum.

No, no, thank you very much for your extensive response and for giving me solid hints to bugfix this issue. Not to mention pointing me to something new (for me) to look deeper into. May sound dumb (IMO it does in hindsight) but I completely glossed over these brush types so far.

ha, ha, it could be my only “complaint” about ZBrush: there’s just so much to discover and learn here, truly exciting IMO.

Thanks again!

The ZBrush program folders should not be renamed. You may wish to perform a full reinstall.

If the default IMM brushes for ZBrush show the Viewer as expected, then we need to look at your content and process.

I notice in the last screenshot you posted that your IMM brush still only reads as having 1 mesh–that little number 1 in the corner of the brush thumbnail. The viewer will not launch for a brush with a single mesh.

Please try the following.

  1. Select the default polymesh3d star from the tool menu, and in Edit mode position it on the screen as desired, and select Brush> Create Insert Mesh Brush with the “new” option selected when asked.

  2. Now, with the star still active, select “Create Insert Mesh” brush again. Since your first single mesh brush should still be active, it will ask if you want to create a new brush, or append it to the existing one. Select “append”.

This will add a second instance of the star mesh to your brush, creating a multi part brush. The viewer should now appear.

Please let me know if your experience matches what I have described.


1 Like

With all due respect: I know what I’m doing here. I maybe a novice with 3D sculpting, not within the world of ICT. A reinstall is not required.

By default ZBrush saves all data and preferences into “C:\Users\Public\Documents\ZBrushData2021”. This folder is dynamically generated by ZBrush during its first start-up. The sub directory “ZStartup” contains all custom config files, such as “CustomUserInterface2021.cfg”, but also the ‘HotKeys’ subdir which contains my custom hotkeys.

So here’s the thing: by renaming “ZStartup” I simply reset things into their default. In fact, when doing so ZBrush creates a new ‘ZStartup’ folder containing all the config files again.

The result is starting ZBrush in full default. Though I could also have moved “ZBrushData2021” out of the way.

Loving it, thank you so much. I highly appreciate this.

Ok, for contexts sake I started this with my custom environment because I also wanted to make sure that the behavior I described above wasn’t caused by my own doing. My plan was to reset ZBrush if this procedure failed (and then try again), but it worked like a charm:

Also: I have a habit of resizing my screenshots from 1920x1080 to 1280x720 because this decreases the size of the files while it can still get the intended message across. For clarity sake I didn’t do this with my above screenshot.

I also think I finally understand what was causing my issue… You already mentioned it above though: 2 meshes. But I misunderstood: I figured that I used 2 meshes in my last screenshot because there were two separate sub tools, so nothing merged. I assumed that this was the needed difference from the tutorial (they merged sub tools).

Am I right to conclude that in the end the changes in ZBrush superseded the tutorial I followed?

It did indeed!

And could you please let me know if my shared theory explains my situation?