Huion Tablet - No pen pressure

Hi guys,

Just ben playing around with the tablet settings with my Huion Kamvas Pro 20(2019) and | realise I have no pren pressure at all. Full to light pressure results in the same presure in all brushes and i’ve set the preferences to non-zero settings and using WinAPI. Should I have the tablet set to windows ink or won’t that help?

Thanks everyone


Hello @simonbad-fox,

The other users on the community usage questions forums are unlikely to be able to help you with system specific technical issues. Please contact Pixologic Support.

The first thing we will probably advise you to do is to re-download a fresh copy of the latest drivers for your device and to reinstall them, if you’d like to save yourself some time.

Thank you! :slightly_smiling_face:

Thanks Spyndel. Yep have just done that after reading another thread.
Will give that a try and then go from there… Appreciate the help!


Wow, there’s a pleasant surprise…

I downloaded a “latest” from the Huion website and then it automatically downlaoded an even newer one…
And yep, it works!

So everyone make sure you have the latest drivers if you have a Huion screen tablet!


Great news! Thanks for posting that. :+1:


Hi SImon,
I’m having the same problem with my Kamvas pro 22 (2019).
I tried re-installing the latest driver but it’s still not working.

Could you tell me wich driver you installed?



Hi Mfontaine,
Sorry have been away so just read your message.

The latest Huion Kamvas Pro 20 (2019) driver that got dowmloaded was

Hope that helps.


thanks Simon