Force zbrush to delete layer details

I have a mesh with 4 lvls with sculpted details on separate layers. If I turn off all layers, go down to subdivision level 1, and choose delete higher subd levels , I expect these details to be erased from memory. However when i subdivide the mesh to lvl4 and turn a sculpt layer back on I get all the details back…
Is this a bug? The only workaround atm is to create a morph target at lvl1 and morph it on a new layer… but this is very time consuming when you have many layers.

Hi, turning off layers with the eye icon or deleting higher subdiv levels will not delete those layers ; you need to delete each of them with the X button layers


I actually don’t want to delete the layers. I just want to delete any subdivision levels above level 1. This is really useful when doing blendshapes. I don’t want the higher subdivision levels to add details.

Hello @JJArtworks

I’m not certain what you want here. If you want to delete those layers, @JJArtworks has explained how to do this. As you have already discovered, deleting your higher levels of subdivision will not delete them. This is working normally. If you want to keep the layers but not have them contribute to the appearance of the mesh, toggle off their visibility.

Sorry hopefully this will explain it better :

I’m creating blendshapes for a character and use sculpt layers for this.

Lvl1 will be the production mesh I use in Maya and it will be rendered with displacement map.

When I create these blendshapes I prefer to use subdivision levels (usually up to lvl4 or 5)

Let say I have done all my blendshapes now and I want an accurate view of how the shapes will look when rendered with displacement;

1.I turn off all layers, go to lvl 1, delete higher levels.

  1. I then import the maya mesh (because Zbrush shrinks the mesh).

I now have my production mesh with all blendshapes. Great. But if I were to subdivide this now my sculpt layers adds the details that I thought were erased when I clicked delete higher levels… seems Zbrush keeps it cached.

My plan had been to subdivide to lvl4, import my sculpt details (from an obj, or use morph if stored target earlier). Then I can see how each blendshape will look like with my lvl4 details.
However as this does not produce a reliable result, the workaround is to go to lvl1 , turn on one layer (blendhapes) store a morph target, delete layer, create new layer and morph. When subdividing now Zbrush the layer does not add details. However if I have hundreds of shapes I have to do this for every layer.

If anyone know a better workaround please let me know :slight_smile: