Disable Sticky Hotkeys

Is there any way to disable sticky keys?
Great update guys!! :slight_smile:


Not at this time. We’ve added it to the feature requests going forward.

Sticky hotkeys are actually faster than how sliders have worked before. While holding the hotkey, you simply move your cursor left/right to adjust the slider setting. Releasing the hotkey accepts the change. This means you don’t have any clicking to do. Once you’re used to it, it’s super fast.

You can get the old behavior if you want it by quickly tapping the hotkey.

I hope that helps!

upon launching the update i immediately felt the glitchy behaviour of this implementation :

  1. use new sticky key method. slider lags and hangs for half a second before disappearing

  2. try and use the legacy method and it stutters and locks

seems like in trying to accommodate both it’s clunky on both sides. having the option to enable / disable the sticky keys on a setting / global level would be preferred

1 Like

I agree that there must be an option to disable Sticky Keys. I prefer the old behavior, and this new small feature made me want to switch to older 2021.5 version:(

This has been fixed in ZBrush 2021.6.1

You can adjust the Preferences>Interface>Click>Sticky Keys Activation Timer slider to suit how you work. To disable Sticky Keys - so reverting to the behaviour of 2021.5 - set the slider to 5 (the maximum). Remember to save your configuration (Shift+Ctrl+i).

1 Like

Hi Marcus :slight_smile:

Still the draw menu pops into the side shelf when using a key combination that includes “alt”.
Is there a way to avoid this as well somehow?

Many thanks for making it an option in the latest 2021.6.2 update! :slight_smile: :slight_smile: