Disable Right Click Menu

I like to use Right Click navigation. However sometimes it will popup the quick menu. This menu is also hotkeyed to the space bar. I prefer to keep Right Click navigation and just use the space bar for the quick menu.

Is there a way to disable the quick menu popup from right click?

I don’t think it’s possible. :frowning:

I also use right click navigation, and the QuickMenu popping up is a constant annoyance. I would love to have the ability to disable the shortcut. Anyone know how??

Try this (Preferences -> Interface ->click time 0.01 from user informerman
on cgsociety forums.
Disable rightclick menu?

Unfortunately that doesn’t help.

The right click menu is SO ANNOYING. The heavier the scene gets, the worse it is.

If your a right click navigator like myself, it pops up randomly while navigating, then throws your focal shift to a bad number, or your intensity.

ZBRUSH ppl please fix this! It’s a major oversite in the preferences, should have a TURN OFF option.

The rclick navigation menu is just plain irritating.

So far this seems to work fine for me. :+1:

I agree that changing the click time to .01 does help prevent the QuickMenu from popping up. But this fix unfortunately affects all clicks and brusk strokes. For example, changing to .01 makes toggling visibility and isolating polygroups practically impossible for me. I’ve also noticed brushes acting strangely as well.

The click time solution causes more problems than it solves, and is really a band aid to what should be a simple “on/off” option.


Yeah I had to change the click time back to its default setting. Messes up masking, selections and other things. Really they need a toggle for it. It seems like bad design idea when you create a popup menu that can’t be turned off and then turn around and setup a navigation feature that uses the same input device button. :roll_eyes:


Agreed, I tried the click .01 it does not help. If your trying it with a box in the scene maybe, but most people have a hi poly character with multiple groups of outfit components.

It gets to the point, where every time you ‘right click navigate’ that ‘right click menu’ get’s in the way constantly. Your thrown into the slider for focal shift when you just want to rotate your viewport.

This has been complained about for 4 release patches now, and it needs to be FIXED. Make this a removable feature, it is an annoying, feature that completely irritates the user while they are trying to navigate a heavier scene.

The right click menu btw is useless, I don’t need those features so in my face while I work. I use S to resize my brush that’s about it… take the r - click navigation menu and put it in the trash where it belongs please and thankyou.

Has anyone figured out a solution for this? I also am getting tired of this menu.

ive been waiting for a solution to this for a long time now

Happy to say this is finally fixed in Version 4R4! There’s now a toggle button to turn off the right click menu popup. They also fixed right click navigation while in transpose modes.

Great to know that Pixologic listens to their customers.

Pixo… your amazing. I love you! There i said it! Now please please can you teach Autodesk how to create and update a program the right way??

So glad I finally decided to search for this problem, and finding this thread. This problem has been bugging me ever since they added the otherwise exquisite Rightclick Navigation controls. Thank you Pixologic!

I hope this also solves the anomaly where ZBrush decides to suddenly ‘drop to canvas’ a copy of the current tool, forcing you to clear the canvas and redraw the tool.

Wrong thread

pls remove this post ty.

Thanks so much for this! I have been dealing with this for so long. Incredible!

Have you tried this?

Just disable “Enable Rightclick Pop”

Preferences>Interface>Navigation>Enable RightClick Popup(off)ZB.jpg



when the right click popup is disabled, you no longer have the access to the zmodeler panel you will have to hit the spacebar to show it.

My question is: Is it possible to disable the spacebar-key for that quickmenu?
I don’t like to open the menu with the spacebar (I like the rightclick with my pen to open it), because if I use a brush with the alt-key, often I fail the alt-key and the spacebar opens the quickmenu that i don’t want.