Decimation Master 2021.7 not working on specific meshes

I’ve used decimation master thousands of times and I’ve never had this issue. It pre-computes fine, but then when it goes to apply decimation, it just sits at 0.0% and nothing happens. I’ve let it sit for 20 minutes, nothing. It’s only 3 million polys in zbrush. Only one subtool.

It seems to work fine on other meshes I have, but I’ve ran check mesh integrity on it and I’ve tried exporting it out and bringing it back in. I’ve tried to .obj it. I’ve tried bringing into maya and running clean mesh on it. I’ve tried dynameshing it first. I’ve tried clearing decimation master cache. Nothing seems to work.

Thanks in advance.


Hi Eric,

If you can share the mesh so that I can take a look I will see if I can shed some light on the problem. Send me a private message if you prefer.


Thank you Marcus!

Here is the file >


1 Like

Hi Eric,

Sorry for the delay.

I think this is because of the Preferences>Decimation Master>Uniform Mesh setting. With the setting on then I can get decimation to work only for a setting of about 700K points and above. With it turned off, decimation seems to work normally.

I don’t know why this particular mesh should throw that up. I’ll ask the developer about it.

I hope this helps,

Thank you Marcus! I appreciate your help!

1 Like

I’ve been having trouble with many meshes as well. I tried the setting mentioned above with no luck. I had been using the presets but out of desperation I tried manual pre-processing and decimation and that worked so very strange but at least a workaround that worked for me.

I can’t get Decimation Master to work on ANY mesh. Presets don’t work either. It hangs indefinitely when Pre-processing any subtool. I’ve noticed that “Analyzing Mesh” briefly flashes and disappears. It should be onscreen the entire time it is Pre-Processing the mesh, shouldn’t it?

1 Like