ZBrushCentral

Attempts to use certain Zmodeler functions results in unintended vertices being merged

I’m having this problem in ZB2021.1.1 - attempting to extrude an edge or face polyloop, trying to Qmesh, stitching 2 points, bridge edges: 2 holes - details will disappear all over the mesh from vertices merging. I’ve tried unifying and T-posing using transpose master to achieve the optimal size, I’ve tried masking, and mask by polygroups at 100 & topological on, & changing draw preferences dynamic size to make the influence smaller (I’ve returned everything to normal settings since nothing has worked) and I have always used a mouse in Zbrush because a medical condition that precludes using a tablet, so it isn’t a stylus pressure issue.

Do I just scale it up to avoid this? It feels like WeldPoints is permanently on.

A real problem being that I am zoomed in so close for this detail work and points could be be merging elsewhere on the model outside my zone of attention, and I don’t realize until hours of work later that the entire mesh is plugged up.

Hello @CWR63

Sorry you’re having some trouble!

I have seen this sort of thing reported before in regard to the point welding, but it is almost always the result of a mesh being too large in the Zbrush worldspace. :thinking:I know you said you have checked this, but let’s just make sure we’re on the same page.

For best results in Zbrush, a mesh should have a Tool> Geometry > Size XYZ slider value of approximately 2, give or take. The Unify function reduces it to this value. When this issue is reported, it very often turns out to be drastically larger than this value.


Double check the dimensions of your mesh in that menu. Understand that the QMesh function is supposed to weld points and is governed by snapping behavior, but the Polygon > Extrude function does not weld points under normal conditions.

If it is more or less properly sized and still produces the unintended point welding, I have no explanation for the reported behavior. You should submit the tool that can reproduce the issue to Pixologic Support.

Good luck!

It was actually much smaller, at .21 - unfortunately after unify the results for point stitching were the same as before, even though it is now XYZ Size 2. I will test the other functions in Zmodeler that are giving me problems - on a previous project where I first encountered this, neither bridge edges nor bridge 2 holes worked, on this one bridge edges does work but bridge 2 holes still does not, irrespective of whether edges are creased or not. Here is Qmesh before:


and after:

Extrude edges looks fine this time, but extrude faces looks exactly like Qmesh does down to the same faces disappearing (not flipping, turned display double faces off and on to be certain).

Is it Windows 7?

I have no explanation for what I’m seeing in the screenshots. One thing I’ll mention is to make sure that the unexpected changes are actual changes to the geometry, and not simply an issue with the display glitching out. Sometimes the display can partially freeze and not fully update until you navigate the model and force the screen to refresh.

If the changes persist even after rotating the model, then I’m out of ideas. I don’t experience this issue at all. As I mentioned above, you will have to contact Pixologic Support, and provide them with the file they need to reproduce the issue. If there’s an issue that needs addressed, this is the way to get technical attention for it.

It’s not a display freeze or glitch, and it’s occured on multiple files - mostly free or purchased models that I’m cleaning up to use in 3d renders/illustrations.
The first model was a purchased M-41 tank in obj format, all quads for a change, lacking UV mapping but way too complex at 2 million faces, a number that I was attempted to lower so that it wouldn’t choke UV Master.
The model in the screenshots is a free model of an A-10, triangulated as usual (looks to have been modeled in SketchUp originally) also lacking UV mapping but with all the decals formed into the geometry - which is low poly despite having many accurate small details.
So it doesn’t appear to be file dependent, but I still need to check by testing it out on a scratch made model, since it may have something to do with low poly one-sided geometry - although this is what I’ve been doing in ZB for 4 years now; adapting low poly triangulated meshes into quad polygon sub- D 'ed UV mapped models I can use in illustrative renderings.
It doesn’t appear that anyone else is experiencing these issues, but I’ll reply back once I’ve tested on something that isn’t an imported object.

I’m currently diverted but will still be testing this out on 2021.1.2 soonish.

@CWR63 - I learned from the masterful Joseph Drust that there is a setting for Zmodeler Welding Tolerance. Go to Preferences : Geometry : Zmodeler Welding Tolerance. Default is 10. When I have problems with points welding as I move them close to each other I set it to 1. Also worked great for fixing inadvertant welding of points in a tapered profile I was laying down with an IMM Curve brush. Might fix your problem. Of course the Unify advice from @Spyndel still stands, maybe even more so, since tolerances I guess are relative to the extent of the ZBrush world.

Thank you, 8 Man!