Are there any Zscripts to help with Subtool Management or organization?

Hey guys,

I was wondering if there are any zscripts to help with subtool management or organization? I’ve tried NickTools but finding it very slow.
I know all the tricks to helping with management but it’s not enough to manage 80-100 subtools efficiently.


Mike N

Hey Mike,

I accidently hit ‘Auto Reorder’ on an unsaved ZTL the other day and after trying to re-sort 65 SubTools I wrote another Zplugin.

This one has a sorting function that will sort any visible SubTools to the bottom of the SubTool list. It also has the option to rename the tools (the rename is still a slow function b/c it has to export out a *.dat file and import it back in to rename the Subtool.) Finally I also added the option to rename and sort as well.

Anyhow it may be of some use; i’ll probably post the tool it’s own thread in the coming days.




SubtoolOrganizerv1_0.zip (181 KB)

This is exactly what zbrush needs! This should have been a top row post!

The only thing is… I just updated to 4R5 and the rename feature doesn’t seem to work. When trying to use it I get this error.


…or maybe I did not install it correctly?

Thanks again, subtool organization has been always been a bit of a chore, but this helps a lot.

@weirdy: Questions for you =) What OS were you running the plugin in? Windows, or OSX? Also where there any subtools that were named the same or that were perhaps duplicated? (I haven’t made a full post on the plugin b/c I haven’t extensively tested it. I ran a few models through it and a few tests with the ‘Demo Soldier’. )

Any info you can supply while running it (in relation to the error) is greatly appreciated :slight_smile:


Hi Joseph-

I’m running Windows 7 - 64 bit on a Dell. My copy of ZBrush is legit and up to date.

I played around with it a bit tonight, but with not much luck.

Group visible subtools works and is pretty dang handy as it is. When I try either of the “rename” functions, I get the following error.

ZScript Note: Specified execute-file could not be found.
SCRIPT: SubtoolOrganizer.txt

I tried different variations on naming conventions and don’t think that has an effect on it.

I’ll play around with the plug in a bit more. Sorry for the delayed response. Thanks again for developing this. Hopefully you can get the bugs worked out. I’d love to see it be a standard plug-in. Like I said, Group Visible Subtools alone is pretty handy…



Try running ZBrush as an Administrator; some of the scripts use a Zbrush *.dll file (another example of this is Transpose Master.) If you are not running as Administrator ZBrush won’t be able to access the *.dll. Let me know if that doesn’t solve the issue =)


Any chance of updating this plugin to 4.7? The current version doesn’t work any more (64 or 32 bits), even when it shares libraries with the same name than the new nanotile plugin.

Thanks! :wink:

@Altea: Try these :slight_smile: Note if this plugin may fail if you have subtools that have the same name.

ZBrush 4R7 32bit:
UnZip the attached SubtoolOrganizer_v1.3_x32.ZIP file to your \Pixologic\ZBrush 4R7\ZStartup\ZPlugs\ folder.
Restart ZBrush.
Subtool Organizer will be located under the Zplugin tab.

ZBrush 4R7 64bit:
UnZip the attached SubtoolOrganizer_v1.3_x64.ZIP file to your \Pixologic\ZBrush 4R7\ZStartup\ZPlugs64\ folder.
Restart ZBrush.
Subtool Organizer will be located under the Zplugin tab.


SubtoolOrganizer_v1.3_x32.zip (44 KB)

SubtoolOrganizer_v1.3_x64.zip (44 KB)

Thanks! It works now. :smiley:

It would be great if in the future you can add also something that adds before or after the current name instead only overwriting it. But in any case obviously I’m very happy with your excellent plugins.

I have the same issue ! Win 7 Home 64 / Zbrush 4r7 64 bits / Subtoll organizer 1.3 64 bit in startup/plugin64 folderbut still haave that error message : [FileExecute,[Var,dllPath],"FileDelete"fileName]

@Warsoul: Double check to make sure ZBrush is running as administrator; the script accesses a DLL file and you may get this error if ZBrush does not have permissions to run it. Also check to see if you have any duplicate named subtools (this can also cause issues.) You can do this using Subtool Master (see image below.)


Finally here is another plugin called ZSceneManager written by Maxime Rouca that is way more robust then the simple script I wrote. It will allow you to manage your Subtools in a Outerliner-esque format :slight_smile:

Information on this ZBrush ZSceneManager Plugin can be found here: http://exoside.com/


Run has admin, no duplicate subtool name. Still not working.
My Zbrush folder are on E:\Tool\Zbrush 4r7
Maybe the path is invalid ?
It work if i have only 1 subtool visible. If i have 2+ i got that error.

@Warsoul: Global Install path shouldn’t be causing the issue =\ Can you double check to make sure this file exists in the ZStartup Folder (make sure it’s not in ZData): \ZStartup\ZPlugs64\SubtoolOrganizer_4R7\ZFileUtils64.dll ?


Yes it is.


@Warsoul: hmmm hmmm… Not sure =\ I am still thinking it may be related to naming (duplicating tools in the Subtool palette will sometimes cause Subtools to appear to be identical in code even if they are named differently)

Can you load the 4R7_ZBrushSearchLight.ZPR project from spotlight and see if that model will rename for you?

This plugin never was tested as much as my others (hence why I never got to officially releasing it (with images and instructions etc… heh.)


Same message error. With the Default Projector Light in Zbrush demo project.


I made a plugin (“ZSceneManager”) which allows to organize your SubTools in folders. It also provide other operations based on multi-subtools selection (partial export, partial GoZ, rename, incremental rename, VisibilityConfigs, …) .

The dedicated thread is here: (including download link and video)

You can post your comments, requests and feeback in this thread.
I hope this plugin will be useful for you.

Thank you Max33 ! I already see it but i’m fyyking low budget because i need a new Workstation. Mine is 2007. i7 920 ddr3 1600mhz.

I keep my money for that(3000$ CAD)

I really need Substance Painter for my Unity 3.x projects.(160$ CAD)

Your plugin look awesome and usefull but i have to stand with my priority.

Good work. I will get this later when Intel gonna release an monster Entry level Xeon 12 cores.

If you have an 75% sale let me know.

I just learned basics of C# for unity 5.3. So Big Up !

@Warsoul: So if the ZBrushSearchLight isn’t working that rules out Subtool Issues and appears that the issue is the ZFileUtils64.dll not having the user rights to run (not running as administrator?)

For Maxime’s ZSceneManager tool he does have a free version that allows you to sort up to 25 subtools. It is worth downloading and checking out as it is amazing and far superior to this script I wrote :slight_smile: