Adjust - Information, Installation and FAQ


Note: all plugins are now included with the ZBrush 4R7 installer. If you did not install a plugin then run the installer again.

For the latest information see the online docs here : http://docs.pixologic.com/user-guide/zbrush-plugins/

This plugin is for adjusting your Draw Size, Focal Shift and Z intensity settings without interrupting your workflow.

:large_orange_diamond: This plugin is available with ZBrush 4R6.

:large_orange_diamond: Installation

The plugin is automatically installed with the standard installation of ZBrush.

:large_orange_diamond: Frequently Ask Questions

Q: I don’t see Adjust in the ZPlugin palette.
A: If you did a custom install of ZBrush then run the installer again and make sure you install the Adjust plugin.

Q: The plugin doesn’t work. I press the hotkey but nothing happens.
A: Reset the hotkeys by Ctrl+Alt+clicking on the buttons in the ZPlugin>Adjust plugin menu. Store the hotkeys before quitting ZBrush by pressing Preferences>Hotkeys>Store. The plugin should then work correctly.

© 2010 Pixologic, Inc. All rights reserved, Pixologic and the Pixologic logo, ZBrush, and the ZBrush logo are registered trademarks of Pixologic. Various patents pending. All other trademarks are the property of their respective owners.


i can’t get this plugin to work , i follow every step until number 5:

“copy data folder”, what data folder? the zip file i downloaded just has the AdjustDFZsize_4.zsc


i’m very new in the ZBrush world, can anyone help me please?

You’re right, that’s a mistake in the instructions. Sorry about that. :o There is no data folder.

Simply put the AdjustDFZsize_4.zsc in the Pixologic\ZBrush 4.0\ZStartup\ZPlugs folder. Restart ZBrush and you’ll find the Adjust Plugin menu in the ZPlugin palette.

You need to assign hotkeys to the four Adj buttons in order for them to work. Ctrl+Alt+click on a button, then press the hotkey you want to use. It’s simplest to use these:

Adj DrawS - S
Adj FocalS - O
Adj RgbInt - I
Adj ZInt - U

Store the hotkeys before closing ZBrush by pressing Preferences>Hotkeys>Store.

I hope that helps,

thanks Marcus !

did just like u said , works just fine :slight_smile:

I’m having problems with my hotkeys.

When I apply a hotkey to either Adj RBGint or Adj ZInt, they are both affected simultaneously. I’ve tried removing and reinstalling the plugin, resetting my hotkeys, using different hotkeys. On a fresh install if I only assign 1 hotkey to either of them, without assigning any other hotkeys at all they are both still affected.

Is it a bug?


No it’s not a bug. It is default ZBrush behaviour for the 2.5D tools. If you select a 3D tool (such as a mesh that you want to sculpt) the the sliders will adjust independently.

Hello there.
I just find out such a great script!
I have the way to improve it a bit (I believe):
Changes to grow and shrink size by different hotkeys can be mapped after on touch ring at Wacom tablets.
I’m not familiar with scripting, but it definitely can be done.

Sorry for poor english: Does my words make sense??

You’re saying that you can map the different keys to the hotring with clockwise movement triggering one hotkey and counterclockwise movement triggering another. Is this correct?

Yes, it is.

Then my friend, you have no need to apologise for your English! :wink:

Doesn’t seem to do anything (except for setting hot keys) in R2b.

I seem to recall that once a hot key is pressed, the cursor can adjust the size/intensity depending on the key press, and the next click/stroke brings the brush back. Am I missing something?

Aint happening for moi. Mac OS X 10.6.8. Zbrush 4R2b.

To adjust the size/intensity you hold the relevant hotkey and drag the mouse back or forth (without clicking) to change the size.

durr…brainfart strikes again.

Thanks for the memory jog, Marcus!

I´ll stick to the default Draw size of zbrush, maybe the numeric draw size should be an option in the preference menu.

I found this function(Store drws)is invalid
It can not store the draw size.
When I zoom the model, the brush size does not change with it.

Once you have stored the Draw Size you need to press the Reset DrwS button whenever you zoom the model.

Thank you very much!!!


What version of ZBrush are you using?

i just set my hotkeys, adjusted my brush size with S and i see a red dot and no visuals to show how big my brush size is now. i see a slider moving on the top right of my screen and it only moves up. i’m using 4r5. is this not compatible with 4r5???

It works fine for me in 4R5. Can you show a screenshot? I’m not sure what slider you’re referring to. Also, are you on Mac OSX or Windows?