Adaptive Skin not working when using Zspheres

I got caught with this problem when using Zspheres. I created my Zsphere model but when I clicked “A” to preview adaptive skin my subtotal disappeared and just an empty blank space appears in its place, however you could see that it was still there. I could switch back and see my Zsphere again. I spend 4 hours trying to figure this out. Someone helped me on another site, which I was extremely grateful, and wanted to share with this community.

Here is his answer…

You most likely had Draw >> Mrgb turned off when you put the model on the canvas. ZSpheres will display without material or color because they’re a mesh generator rather than having any actual geometry, but the adaptive skin cannot.

Exit Edit Mode and clear the canvas. Turn Mrgb on before drawing the model on the canvas again and returning to Edit Mode. Now when you turn on the adaptive skin preview, you should see the mesh.

Hope this helps someone else.


Marking as resolved in the first post.

I created an account just to thank you so thank you very much!
Also a simple and easy explanation to understand and easy to memorize.
By the way is there any use to generate a mesh without color or material?