Multi Map Exporter - Information, Installation and FAQ

Yes indeed. Figured it out a little while ago and am making great progress, this script is truly a timesaver!

Thanks for the quick response.

Seems I spoke too soon…

Are there any reasons that when using the MME it would NOT create any maps or objects as set from the options? I’m working on something else to find that now when I use it, it acts as though it is creating the maps/objects, but when I check the folder no files where generated =/

I am sure it is a very slight oversight on my part…

Actually, I found that ZBrush was “forcing” the location where it would save too, so it was exporting just fine, just not to the folder I specified, or “tried” to specify. It would “snap” to a location one level up, why, I haven’t a clue =/

Are there any special characters in the tool/subtool names that might be causing the error? I can’t think of why it should happen otherwise.

i m having an issue with NM from zbrush 4, i m getting some artifacts, and looks like its comes from the hard edges on the low sub-D mesh. and its doing to all the object i have tried on.
would if anyone have the same issue



I just had one question that I don’t feel the documentation explains really clearly. In the subdiv level setting on the displacement export options, is that number the level you are generating the map FOR or FROM?

For instance, if I have a mesh with levels 1-6 and the mesh I am exporting to be used in max with the displacement is level 2, would I set the slider to 2 or 6? Logic tells me 2, but when I do that, ZBrush shows my mesh being brought down to level 1 in the viewport when the maps are generated which has me worried that it’s ignoring that setting.

Any clarification of this would be appreciated. Thanks.

At this stage, I’m deleting the lowest level temporarily to generate the maps just to be sure, and it’s a step I’d rather not have to keep doing.


Are you using the Smooth UV option?


The slider is for setting the level that displacement is generated FROM. In other words, if you are exporting your level 2 mesh then set the slider to 2.

You may see your mesh go to level 1 but that is simply part of the plugin operation. Deleting the lower level is not necessary.

that’s what i thought. Ok, thank you for the prompt reply.

And onto his problem… would smooth UV fix that result in displacement meshes too?

If Smooth UV is the problem, yes.

I have a flat plane. A floor tile. I started with an obj. It has 4 faces (8tris). I put about 10 divs on it and project a tiled stone floor on it. I then try to use the Multi Map Exporter plugin

  • with smooth uv ticked it creates a map in the centre with a huge border of nothing around it. the map is accurate but uses about half the uv space i want it to. I want it to fill the area so the normal map is tileable.
    Is there anyway I get the map to fill the entire space? The Uvs are laid out to use the entire space.

  • i went through the pdf readme on MME. It said you can use an original base mesh. So I Stored my morph target, and imported my obj, and used switch MT. This created 3 useless maps, all the uvs seem stretched and moved. I’ve checked the obj and the uvs are fine.
    After doing this option I now produce 3 normal maps everytime, even if restarting zbrush. I just want one useable normal map!!! How can I stop it producing 3??

can anyone help me use this plugin?

I’ve been giving this a few shots, and have been able to recreate what I think is your problem (multiple blank maps on a plane - for me even the regular method of generating a map was blank).

The error was happening when the uv’s borders were directly on the 0 or 1 coordinate boundary, MME/zbrush sees this as extending beyond the 0-1 boundary, and then reads it as multiple tiles according to marcus_civis (here). Scaling the uvs in a tiny bit solved the problem for both generators, and created only 1 map for MME.

“You can check this by pressing Tool>Texture Map>New from UV Check. A UV problem will be shown as red.”

Thanks Cryrid. Thats solved it.


I’m trying to export my maps but it keeps giving me this error: “SubTool skipped, no UVs assigned”. This is weird because:

  • I have modelled the mesh in 3Dmax
  • Unwrapped it in MAX with proper UV’s without any overlap
  • Exported the object as .obj WITH texture coordinates
  • Imported and sculpted in Zbrush.

In Zbrush 3.5 it would never give errors about UV’s with this workflow.

Any ideas?

Cobra 6


Are you quite sure that all your subtools have UVs? I’ve not heard that anyone else has had this error.

Hi Marcus,

Yes I am positive that all my subtools have UV’s. It doesn’t export any maps at all. That’s why I think it is weird.

When I subsequently exportmy sculpted mesh to an .obj and extract the maps via xNormals (application) it works and the UV’s are exactly as they are in 3Dmax.

Cobra 6


Could I have the ztool to test? I would only need the lowest subdivision level of all subtools. If MME is failing to detect the UVs then I need to know why and the only way is to test with your model.

I’ll PM you with my email address.


I will send it to you as soon as I get the email address.

Cobra 6

Thanks, check your PM.

After some messaging back and forth Marcus and I determined that the problem was that I pressed “Make Polymesh 3D” after importing which basically makes a clean clone of the object, deleting all the UV’s.

So if anyone runs into it, here is the solution :slight_smile:

Cobra 6

thanks so much!, i had this problem too and found it very frustrating. This should be added to the FAQ section of the first post. i had trouble finding this post.