Help regarding Zbrush Performance

To begin, Id like to apologize if I am in the wrong section, but I am not only new here, but also in the world of Zbrush.

My question is regarding of the software performance.
I’m experiencing a lot of lag in the response when it comes to the brush.
As I am new to Zbrush, I still develop very simple sculptures, which leaves me confused with such slowness that I am facing with only 300k + - of active points.

Here are some screenshots of the software summary and my specs:
zbruhinfo zbruhinfo2

****SPECS **
Running on WIN10 PRO,
2.50 Ghz intel core i7 - 4710
12 gb 2494 MHz DDR3
Nvidia Geforce GTX 850m

Thank you regards

Hi @MauricioMello Welcome to ZBrush Central!

You are in the right section.

Make sure that you don’t have Dynamic Subdivision enabled. Go to “Tool > Geometry > Dynamic Subdiv” and turn off the “Dynamic” button. Trying to sculpt with this enabled will cause a lot of lag.

2020-07-08 05_16_46-ZBrush

Hello @zber2 Thanks for the quick return.

Well, I was reading some topics and yesterday I did a good research and I noticed that some people had Dynamic Subdivision and Dynamesh activated, so I went to check it out and soon I noticed that these are not my case, which made me even more confused.

To specify a little more, I am sculpting only one Tool / Sub-tool.


Which version of ZBrush are you using?

Dynamic Subdivision is usually the only thing that will cause your brush strokes to lag badly. Your computer meets the required specifications, so that is not the issue and 300k points isn’t a lot. I can’t think of anything else it might be. Unless @Spyndel might know of some other causes, I would recommend that you contact Pixologic Support. Go to that page and click “Start a conversation” in the upper right of the page.

Other than Dynamic Subdivision, I cant think of anything else that would cause genuine “lag” in a mesh of only 300k points in hardware that meets or exceeds the recommended specs.

However, new users sometimes interpret ZBrush’s normal brush behavior as lag. Zbrush works best with a slow, steady stroke. If you move the brush too fast, your stroke will separate into dots, regardless of mesh density, though Lazy Mouse can affect performance in this regard.

Lazy Mouse is a feature that aids users in making smoother more accurate strokes, and is enabled by default with many brushes. However, it does come with a bit of a performance tax, and sometimes you can make faster, more responsive strokes by disabling it–( L ) key by default.

Other than these, without getting a look at what’s happening on your end, I couldn’t say what you’re experiencing. Performance issues can be caused by tablet issues, heat, power management settings, etc. But if you feel the program is not performing as it should on your hardware, you will need to contact support as Zber2 suggested to take a closer look at your configuration.

Hello @zber2 and @Spyndel , thanks for the support.

The version of Zbrush I’m using is 2020.1.3

I made a screen recording to demonstrate a little of my situation:
Zbrush Lag Issue

Note that the lag is very noticeable while I am carving with Alt +

I thought the problem could be fixed with some settings … like maximizing the Sculptris Pro tool as I’ve seen in some videos and similar topics, but I’m still lost.


The problem might be that you’re using a custom brush. That’s one of the Ryan Kingslien brushes and was made with a much older version of ZBrush. You’re taking a chance using things that were created in older versions of ZBrush. I would suggest that you use one of the brushes that ships with ZBrush and alter it to do something similar. As an example that might match the RK_Ball Stylus brush is the Clay Tubes brush using Alpha 35 from the Alpha palette.


I didn’t think about this possibility, which really makes sense, but I tested other brushes, alphas and the problem still persists as you can see in the video below:

ZBrush Test 2

I would suggest that you contact Pixologic Support. Go to that page and click “Start a conversation” in the upper right side of that page. Include the links to the two videos.

I will do,

Thanks you anyway for the support.

OK, after viewing the video, there are a few things.

  1. Upgrade your program. The current version of the program is 2020.1.4. Obsolete program versions arent supported and may be missing fixes. You will want to be using the most up to date version of the program before contacting support. This is free for registered users.

  2. As Zber2 said, it would be best to do your performance test with stock brushes. Custom brushes are going to add unknowns. Just use the Standard brush in normal (not sculptris) mode to get an idea for how ZBrush is performing. Different results with different brushes should be chalked up to the situation, and not a program-wide issue.

  3. The brush you are using is in Sculptris Pro mode. Sculptris Pro adds geometry in real time, so there is a much higher processing burden. Depending on the situation and the settings in the Stroke > Sculptris Pro menu , you would expect slower performance, especially when paired with Lazy Mouse. Both lazy Mouse and Sculptris Pro modes come with a performance tax.

Based on the video, I’m not certain I see anything especially unusual that can’t be chalked up to using a more resource-intensive brush.

Hello @Spyndel

I decided to do a test and start a new model without using Sculptris mode.
I managed to reach 2,080Mil Polycounts and Active Points without any problem. No lags using only Divide to give a better resolution.
What strikes me is the fact i was getting to 300K KP and Active Points while using Sculptris Mode and witnessing all that lag.

What confuses me is the possibility that this is a configuration problem or my setup is in trouble.

There’s not necessarily anything unusual going on. As I said, Sculptris has to change the topology in real time as it makes a stroke. This will require more calculation and processing power than simply displacing the existing points. The performance will vary greatly with how many polygons you’re asking it to create at once, which will in turn be affected by brush size, underlying mesh topology, and the brush settings. I dont really know anything about the brush you’re using, which is why it’s useful for testing purposes to limit your testing to the stock brushes.

ZBrush traditionally performs very well on modest hardware, letting you sculpt pretty smoothly on really dense meshes. In fact, the traditional brushes will be able to sculpt smoothly on meshes that may still be too dense for other more CPU intensive functions.

Sculptris Pro is a different animal than the traditional brushes though, and one of the reasons its usefulness is mainly in the low to medium detail stage of mesh creation, while the traditional brush mode is used with multiple subdivision levels to sculpt the finest detail.

Hi, I’ve actually been running into the same issue since Sculptris Pro came out. I was messing around with it last night and found that If you go to the Brush Palette then in the “Samples” section turn on the “Fast Samples” option(right next to the Build Up option) that brush lag won’t be noticed until you reach about 1.5 million polys instead. It seems to work well even on custom brushes. Hope that helps.