GoB: an unofficial GoZ for Blender.

It works and nice too . But the model is imported upside down in blender.
It’s actually 180 degree roteted on x axis in blender. Could it be solved?

poster123 :
This GoZ for Blender is causing undesired changes in my Zbrush 4 Export/import preferances.


This GoZ for Blender is not working as desired. I have noticed 2 things that are wrong. When I hit the Goz button in Zbrush to jump to Blender.
  1. My model is vertically inverted in Blender.
  2. The Export/Import options of Zbrush 4 are then changed undesirably
  • I've attached a image showing the before in Zbrush 4.
  • A model in Blender as opened with the GoZ button of Zbrush 4
  • And the annoying changes in the Zbrush Export/Import preferances
So with these problems in mind how can we make the GoZ for Blender better?![GoZ-for-Blender-mess.jpg|1100x1035](upload://fcE2MhpFWUXaoRhrkW9p56lOC9N.jpeg)



Good to see that someone has taken the time to work on this. A matter of time before the bugs are worked out.

An update of the script.
Blender is not automatically launched (I know it is bad),
but now you can use ZBrush and Blender at the same time for a complete project in example.

known problem:

  • all objects may have a different name.
  • it is better to start a project from ZBrush and then export it to Blender.

Please do not look this video (it is a rhino-monkey :o):
[video=vimeo;30978385]http://vimeo.com/30978385[/video]GoB_v2.3.zip (8.88 KB)


This new script seems to work.
I have Zbrush 4R2 installed with Zbrush 4.
The modification used in your earlier methods are still applied to the contents of the
C:\Users\Public\Pixologic\GoZApps\Max folder.

I’ve multiple versions of Blender
The earlier script you had us use the
C:\Users\Public\Pixologic\GoZApps\Max\GoZ_Config.txt to path to desired version of blender

The new script GoB_2.3.zip opened the earlier version of Blender targeted in the GoZ_Config.txt

So I modified this GoZ_Config.txt to target my most recent version of Blender 2.60

And now it works!

Thank you Staunton.:+1:
This is a very good plug-in.
It works fine in Blender 2.60 version.(The seems to be small problem . And it works fine.)

Thanks Stunton,
It works :slight_smile: I’m like cgmystic though, it pointed to earlier versions of blender… but pointed it to the newer one :slight_smile:

I noticed that it won’t apply mirrors (or modifers in general I guess) though during the export, I tried a piece I’m working on and it only exported the actual half that I’m working on, not the mirrored…

Anywho, Thanks again :slight_smile:


Seems to doesn’t work well for me.
Blender to Zbrush works really fine but Zbrush to blender just do nothing :confused: (i mean nothing appear in my Blender Viewport while pressing GoZ).

Blender 2.6 Rev:41281 (not install, only archive)
Zbrush 4 RC2

Thank’s for your work :slight_smile:

Hi bobyy.
Try as see below.

Damned ! Didn’t notice the blender icon :o

Thanks a lot for your help and have a good sculpt :smiley:


Cant thank you enough for developing AND SHARING this Blender/ZBrush bridge. I’ve been hoping to see this for years now. Your efforts are appreciated :-).

Time to do some OSX Blender 2.6(trunk) to ZBrush testing. Very excited to be able to finally have GoZ, or rather GoB :wink:

I’m getting an error when using the 2.3 script on my Mac (OSX 10.7.2). I downloaded the script and Extracted the ‘ZBrush’ directory contents to:/Users/Shared/Pixologic/GoZApps. Set the goz preferences in Zbrush to find my blender 2.59 app - all is good with the Zbrush part.

For the blender add-on component I placed the GoB_addon_259 folder and contents into “Macintosh HD/Users/imac/Library/Application Support/Blender/2.59/scripts/addons” and changed the init.py pathGoZ = “C:/Users/Public/Pixologic” to “/Users/Shared/Pixologic”. When I follow along the video with the rhino, I export out of Zbrush and then go to import into Blender with the blender icon in the header, I get this error:


What am I doing wrong?

P.S. Tried this with Blender 2.60a and received the same type of error.

I’m in OSX 10.6.8
Blender Trunk (v2.6x) r41599

is there a new version of “pixoGozFile_for_Mac” that is needed to get GoB working 2.6 trunk

it looks like the already compiled “ext_GoB.pyc” is relying on windows-specific filename paths. as opposed to generic path variables to be passed in, or even mac specific paths with structures like “(uc/Users/designusername/Library/Application Support/Blender/2.60/scripts/addons_contrib/GoB_addon_259/)”

I’ve performed the same fixes to init py as Dougt mentioned. And am able to send objects TO ZBrush from blender, however, I am not able to reImport the GoZ data back into blender when clicking on the blender icon in the menubar(within blender). I get the same error, which looks like its arising from and “D:” drive based file path, that looks to be hardCoded into the “ext_GoB.pyc” file. Has any one found a means of defining the filepath that “ext_GoB.pyc” is attempting to use? This looks to be the last glitch preventing OSX usage of GoB that brings the mesh back into Blender.

Hello Mac users,
We found with doug some mistake in ext_GoB.pyc
use the new attachment file for Mac.

All paths are only in the “init_.py” file.
So edit this file is a good thing, the default path is for Window.

Two lines need to be modified is the “init.py” file:

line44 pathGoZ = “C:/Users/Public/Pixologic”
line126 os.system("{0}/GoZBrush/GoZBrushFromApp.exe".format(pathGoZ))

Can you post your modif from line 126, because I need the GoZBrushFromApp name on Mac to send back a Mac specific version of GoB.

Thx for the help.ext_GoB.zip (5.29 KB)

@Stunton thank you for your help :slight_smile:

my mac-specific init changes are as follows:

line44 pathGoZ = “/Users/Shared/Pixologic”

line126 os.system("{0}/GoZBrush/GoZBrushFromApp.app/Contents/MacOS/GoZBrushFromApp".format(pathGoZ))

mac OSX looks at an “.app” file as a folder/package(which it technically is in OSX). Thus I have to navigate to the internal executable.

Thank you again for all your help and hard work to bring GoZ to Blender users(across many platforms)!


after installing the new “ext_GoB.pyc” you posted, I was able to use the same(edited) init py that I changed previously, and am now able to bring GoZ objects back into Blender; so now all seems to be working well with GoB! Thank you!!! :slight_smile:

I’ve only tested passing meshes(with and without masks) back and forth, all seems to work as expected, aside from one issue… it looks like normals need to be recalculated on reImport back into Blender(from ZBrush) if the object had a subsurf modifier on it when sending it to ZBrush. A few of the normals come back into blender flipped, until I enter then exit edit mode on the object, then all is well with the normals. I’m of course aware that the subsurf modifier isnt applied when sending the object to ZBrush, only the original mesh is passed back and forth, its just that a potentially missing normals recalc(forced via python) isnt happening on remiport, just my first guess.

Thanks uaun,
I have corrected this (a)normal behavior.
Now two version, one for Windows and one for Mac :smiley:

Only a redraw and paths corrected for this new version.GoB_addon_v24 for Mac.zip (9.23 KB)GoB_addon_v24 for Windows.zip (9.22 KB)

Thanks for the updates my friend, You are awesome…
Beers for you Sir!!! _/_/_/_/

Whoa - so glad I ran into this thread! Thank you so much for making it!

i, thanks for making this I am using Mac OSX 10.58. Can you please tell me if this latest download will work and how to install/set this up. Thanks

I somehow got this to work with Blender 2.60a but not with the 2.60.5 from graphicall.org.

I’m confused how to set this up and get it working. What are the exact steps to install completely on the Mac OSX system? I’m running ZbrushR2 and Blender 2.60.5