Contour problem with a brush

Sometimes the square edges of the alpha appear, how do you make them invisible? I pushed up to 45 million in subdivision and the problem remains the same :exploding_head:

Hi @MrCedric Welcome to ZBrush Central!

Increasing the Focal Shift slider will soften the edges. You have yours set at -77. That is too low. Set the slider to 0 and work from there until you get it to where you want it.

1 Like


So I have tried and you were right for the sharp square edges. :+1:
But there is still a problem, kind of steps remain visible :fearful:

:pleading_face: I’m still stuck, someone knows how to avoid this lines :sweat:


(sorry the upload made ugly picture)

I have tried to make better example, here I think that you can see the lines…

Can you share the alpha or brush? Those lines simply look like features of the alpha rather than anything ZBrush is doing.

sure, here is the alpha…!
(I made a jpeg because Zbrushcentral don’t allowed psd)

Thanks but that won’t work! Can you upload somewhere (Dropbox for example) and give me a link (in a private message if you prefer). I need to check that the original alpha is 16 bit grayscale. If it is 8 bit then that would explain the reason you are getting those steps. Converting to jpeg will probably automatically convert - anyway, the file you have posted is 8 bit.


Sure, please find the alpha. I put another one with the same problem…

Many thanks, that’s great.

Although these files are 16 bit they have clear “steps” that I’d expect to see with 8 bit. I wonder ifperhaps they have been converted from 8bit. The steps are most noticeable in the Clay alpha. Here’s the Rock alpha with the levels adjusted. You can see the stepping and how it is exaggerated in ZBrush.

Here’s the same alpha with some blur applied. If you try it in ZBrush you’ll see the stepping has largely disappeared, at the expense of some definition.


I tried this new alpha and I add one more subdivision like you could see, but same result, steps… :exploding_head:

OK, then can you post the brush so that I can examine the settings?

Sure, please find it here :wink:

Great, thanks. I think that is basically because the brush is using the “Roll” setting in the Stroke>Modifiers. Because the alpha is repeated it overlaps and causes the lines, especially if the stroke curves or backtracks. As it’s for rock I suppose the creator thought it doesn’t matter too much.

This is actually a good candidate for using the new surface noise local projection mode. I made a brush for you which you might find useful. It’s for ZBrush 2022 and won’t work with earlier versions.

Rock_Surface.zip (116.2 KB)

Thank you very much, there is still some lines but it is better :wink:
Where I can study the “new surface noise local projection”?


There are also two new brushes that use it: Pattern01 and Pattern02

Thank you very much for your help, i go right now to study and try the “noise local projection”
All the best :wink: