1. #1

    Question Zscript disappears?

    Loading a Zscript in the usual way Shift+Ctrl+L and then to open up the script panel with H. So far, so good. Now carrying on sculpting I would expect that script to remain in the script panel, but sometimes I go back and it's gone. What causes this? Can it be unloaded with an undo?
    Last edited by Britney Zpheres; 03-20-17 at 01:08 PM. Reason: My terrible spelling

  2. #2
    Moderator Follow User Gallery
    Join Date
    Jun 2004
    Location
    UK
    Posts
    10,445

    Default

    This is probably because you used a plugin or macro. Only one zscript/plugin/macro can be loaded at a time. Plugins and macros have their buttons as part of the main interface so don't disappear when they are unloaded but zscripts are only temporary so do.
    You can either load the zscript file again or pressing the ZScript>Previous button will reload it (if you've only used one plugin or macro).

    If you've got a zscript you use often then make it into a plugin. It saves a lot of hassle.

  3. #3

    Default

    Turning a ZScript into a plugin is the plan. Just got to figure out cases for if not selected / not the right subtool / got too many spoons etc and then convert it to plugin as I understand it is easier to fix a Zscript than a plugin.

  4. #4
    Moderator Follow User Gallery
    Join Date
    Jun 2004
    Location
    UK
    Posts
    10,445

    Default

    It's easier to test and fix the zscript because you can just reload it to see the changes. With a plugin you need to restart ZBrush.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •